2

I have a ftp server running on Cent OS VM. the goal:

  • public map can be seen by everyone (readonly for anonymous users, write for logged in users)
  • upload map can only be seen by local users logged in and they can upload files (= write permission)

I can't create files with Filezilla (also not in the public folder) if I log in with a local user account of ftp server

I also set this bool value:

setsebool ftp_home_dir on

my vsftpd config:

anonymous_enable=YES
anon_root=/srv/shares/public
local_root=/srv/shares
no_anon_password=YES

local_enable=YES

write_enable=YES

local_umask=022

I get an 553 could not create file

Are there any setsebool values that I forgot to set?

1

If you suspect SELinux as the culprit (ie, if any violations show up in /var/log/audit/audit.log when you attempt the upload or if the upload completes successfully after setting SELinux to permissive mode), then look into audit2allow to turn your failure audit messages into SELinux rules that will allow the actions you're attempting to perform.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.