I installed CentOS 6.4 within VMWare 7 by easy setup. Afterwards I had to change locale settings to German. Everythings works fine accept that the clock on the login screen is still in 12-hours-AM/PM-format. I want to change it to the 24-hour-format.

GDM Version is 2.30.4.

I tried the suggestions from the answers to a similiar question and another question. However, the suggested command gconf-editor seems not to provide a way to configure the clock format at the login screen.

The other command gsettings is not available in my environment. How can I obtain it?

There are other suggestions involving gdm.conf but the only gdm.conf in my environment is a XML file and not located in the directories specified in these suggestions.

At Red Hat there seems to be a support article about this issue, however bp;dr.

How can I set the login screen time to the 24 hour format?

  • gsettings is part of the package glib2. – slm Aug 15 '13 at 13:41
  • @slm Thanks! glib2 is already installed and there is no gsettings in the file system. In gnome-control-center I did not found an appropriate option. – Claude Aug 15 '13 at 14:30


Don't know exactly how to do this but here are some things to investigate.

  1. gdm cache dir. I don't know how to change it but I found this: https://help.ubuntu.com/community/Locale. Looks like there is a file dmrc which some settings related to GDM.

    for example

    My file is located here for user "saml", /var/cache/gdm/saml/dmrc.

  2. gnome-control-center

    There are several configurations accessible through the control panel (gnome-control-center) for GNOME which may allow you to change this setting.

  3. Official docs

    The official documentation for GDM is located here for the various versions. Looking through it I didn't see a method to change the time format however.


$ sudo -u gdm dbus-launch dconf write \
                 /org/gnome/desktop/interface/clock-format "\"12h\""

Change the format to '24h' for 24 hour format.

  • Thanks a lot for your investigations! (1) in /var/cache/gdm/[user] are no files or dirs, (2) did not found anything approproated in the control center, (3) did not try. With your Gnome3 hint I tried to add clock-format but got errors. However, I tried to add the key "clock-format" manually with the gconf-editor. It doesn't work but probably because the key has not been bound to a schema. Searching on the net gsettings seems to do the job right but I failed to find a installable package. Finally I ended up installing CentOS manually with the right locale. Let you know, if it works. – Claude Aug 16 '13 at 6:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.