1

When using Putty to connect to the router using telnet protocols, and then I pressed Enter key, there were two carriage returns in the text, how do I get rid of one of them?

  • What kind of router? How did you configure Putty? – Gilles Aug 15 '13 at 22:04
1

I am not sure but here for you to try.

PuTTY may add one more "CR" when it see "LF", that the cause of double "CR" chars.

Look your configuration at "PuTTY\Terminal\Implicit CR in every LF"

enter image description here

  • {Look your configuration at "PuTTY\Terminal\Implicit CR in every LF" } thanks – nick Aug 17 '13 at 1:40
  • @nick: Do you claim that with disabling “Implicit CR in every LF” you got rid of the duplicates? And how duplicate CRs may be visible at all in a text window? – Incnis Mrsi Aug 19 '15 at 17:57
0

Others have stated that the "Implicit LF with CR" and Implicit CR with LF" ONLY control how PuTTY interprets what is coming IN. An IMPLICIT CR or LF wouldn't have much value down the wire. A command for an EXPLICIT CR or LF would be handy, but that doesn't seem to be available.

0

This may actually be due to the return key setting under Connection > Telnet

Try unchecking "Return key sends Telnet New Line instead of ^M"

The Implicit CR/LF options only affect how new lines are displayed, not what is sent to the server.

Double Enter Fix

0

my solution

Just edit "Flow control" to "None" it works for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.