2

My OS is debian squeeze and I installed kde as graphical interface. My current kde version is 4.4.5. But I want to update it to the newest version (4.10.5). How to do it?

1

According to the packages list 4.10.5 havent made into Squeeze yet. But is avaliable in Sid. You can add Sid packages to your sources.list and install the packages from there. The problem is KDE uses a whole bunch of libs which might break when combined with your current setup. As squeeze is really "old" I'm not sure they will backport kde 4.10 to it. According to here: August 24, 2010 As Squeeze has been frozen, Debian will ship Squeeze with KDE 4.4.5. Unstable repos will have 4.4.5 too until Squeeze release. KDE 4.5.x will be available via other repo some time later.

Seems 4.10 wont make into your release. Hence I suggest you to dist-upgrade.

|improve this answer|||||
  • I followed this tutorial (digitalocean.com/community/articles/upgrading-debian-to-unstable) to upgrade squeeze to sid. The problem is that I didn't get any questions to answer during dist-upgrade (like he said) and after repeating dist-upgrade I get these errors: E: Couldn't get lock /var/cache/apt/archives/lock - open (11: The ressource isn't available) E: The directory /var/cache/apt/archives/ can't get locked .. My sources.list: deb ftp.de.debian.org/debian sid main deb ftp.de.debian.org/debian squeeze main deb ftp.de.debian.org/debian sid main contrib non-free – user1429101 Aug 14 '13 at 18:27
  • Have you ran the update till the end? Was it successful? – vfbsilva Aug 14 '13 at 19:04
  • I don't really know.. I got a really big changelog and didn't saw any errors. Atm KDE still reminds me of 214 updates.. but dist-upgrade isn't working as I said. – user1429101 Aug 15 '13 at 10:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.