2

Seen similar question many times on AskUbuntu, but most answers was bout unity-helpers or gconf ...canonical... etc, so this actually doesn't seem to work.
The problem is that I decided to move to lightdm from gdm. Yep, it works,but I can't setup background image to it - always getting black bg color in exchange of picture.
My configs:

tempos@parmasse ~ $ cat /etc/lightdm/lightdm-gtk-greeter.conf 
#
# logo = Logo file to use, either an image absolute path, or a path relative to the greeter data directory
# background = Background file to use, either an image path or a color (e.g. #772953)
# theme-name = GTK+ theme to use
# icon-theme-name = Icon theme to use
# font-name = Font to use
# xft-antialias = Whether to antialias Xft fonts (true or false)
# xft-dpi = Resolution for Xft in dots per inch (e.g. 96)
# xft-hintstyle = What degree of hinting to use (hintnone, hintslight, hintmedium, or hintfull)
# xft-rgba = Type of subpixel antialiasing (none, rgb, bgr, vrgb or vbgr)
# show-language-selector (true or false)
#
[greeter]
#logo=
background=/usr/share/backgrounds/lightdm.jpg
#background=#772953
#theme-name=Adwaita
#icon-theme-name=gnome
#font-name=
#xft-antialias=
#xft-dpi=
#xft-hintstyle=
#xft-rgba=
show-language-selector=true

The file itself:

tempos@parmasse ~ $ ls -la /usr/share/backgrounds/lightdm.jpg
-rwxrwxrwx 1 root root 1362684 авг 14 12:36 /usr/share/backgrounds/lightdm.jpg
  • Does your image file has correct permissions? Try to copy it to the default directory /usr/share/backgrounds/. – dsmsk80 Aug 14 '13 at 12:23
  • @dsumsky As you can see below config, it's already in this directory and has 777 rights – Constantine Kozlov Aug 14 '13 at 12:34
0

You can try removing alpha channel from your background image (you can do it with gimp).
for check if it have an alpha channel you can do:
file /usr/share/backgrounds/lightdm.jpg

If it have an alpha channel it will show 'RGBA'.
A means Alpha channel.
so without is 'RGB'.

if without not work, you can try adding new one:

convert <input> -alpha on <output>

If you cannot set by configuration file of lightdm because of some strange problem you can do it using feh.

(feh — image viewer and cataloguer)

It have not so many dependence and is good for see image file.

from feh you can set background/wallpaper almost everywhere

feh --bg-fill /usr/share/backgrounds/lightdm.jpg

BACKGROUND SETTING
feh can also be used as a background setter. Unless you pass the --no-fehbg option, it will store the command line necessary to set the background in ~/.fehbg, so to have your background restored every time you start X, you can add "eval $(cat ~/.fehbg)" to your X startup script (like ~/.xinitrc).

0

Thanks all.
Seems, that it was some bug - in lightdm itself (meening package-specific or some libraries) or, possibly, it was simply installed with some errors/bugs. I'm now trying to install many different things, like compiz, awesome, enlightenment, lightdm and others, so can't be sure.
The fact is today both lightdm and lightdm-gtk-greeter received updates, and this fixed background's problems even with original images and config.

0

I found a solution :

I picked my preferred wallpaper and copied in the directory provided by aliceinwire.

sudo cp your-wallpaper.jpg /usr/share/backgrounds/lightdm.jpg

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.