7

I'm trying to install Arch Linux on a new system with a Gigabyte GA-Z87N-WIFI board. Although I can use the USB keyboard (and mouse) in the BIOS, the keyboard doesn't seem to work at all once I boot off the boot DVD.

There are several people who've solved this problem by enabling IOMMU in the BIOS. I couldn't find an option called IOMMU, but I found VT-d, which I believe is the same thing. It's enabled.

Also, Arch detects my (wifi) network card and attempts to run DHCP on it. I don't know if this is relevant, but I think I remember reading that if IOMMU is disabled network cards aren't detected.

EDIT: I tried disabling UEFI in the BIOS, just in case... No change. I still have no keyboard.

EDIT 2: I think maybe appropriate kernel modules for my USB controllers aren't available (or aren't loading?) I went into hardware info from the install disk boot menu, and under PCI Devices, I can see three USB controllers.  The "product" line reads:

8 Series/C220 Series Chipset Family EHCI

Vendor is Intel Corporation. Module is unknown.  Maybe this is the issue? Most other devices have modules listed.

EDIT 3: This seems to be an issue with the install disk kernel, apparently it doesn't support the Logitech unifying receiver: https://bugs.archlinux.org/task/35991

The kernel mentioned in that bug report is in fact on the current 01/08/2013 install disk, and I have a unifying receiver. I managed to boot a Gentoo minimal install disk off a USB stick and the keyboard was fine. So I think I've answered my own question. Unless anyone has anything to add...?

  • VT-d is for hardware-enabled virtualization support such as KVM – justbrowsing Aug 14 '13 at 11:13
  • I knew the two were related, but there's an Ehow that indicates they're labels for the same setting: ehow.com/how_7705109_enable-iommu-bios.html – rainbowgoblin Aug 14 '13 at 18:13
  • My point was it's not going to help unless you installed ArchLinux in a Virtual Machine. Sorry. – justbrowsing Aug 14 '13 at 18:15
  • Oh. Right. That's a good point. – rainbowgoblin Aug 14 '13 at 18:19
0

The kernel used on the August 2013 install disk, 3.10.4, apparently doesn't include support for the Logitech Unifying Receiver. The problem seems to have been fixed in the 3.10.6 kernel: after I installed Arch using a wired keyboard, my wireless keyboard worked fine using the unifying receiver with the Arch kernel that was installed (3.10.6). I also compiled my own 3.10.7 kernel and my wireless keyboard is still working.

Most of the bug reports and forum posts relating to this issue come from Arch websites, but I found a post from a Ubuntu user, so this may or may not be a more general problem.

0

In my case I looked at the BIOS options for my LanParty motherboard and found that I needed to enable the USB keyboard. That solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.