1

I am brand new to linux and am unable to connect to the internet in Fedora 19. When I type ifconfig I get:

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 150  bytes 12792 (12.4 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 150  bytes 12792 (12.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

p9p1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::96de:80ff:fe2d:8274  prefixlen 64  scopeid 0x20<link>
        ether 94:de:80:2d:82:74  txqueuelen 1000  (Ethernet)
        RX packets 85  bytes 11964 (11.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 94 overruns 0  carrier 0  collisions 0

Also when I type netstat I get:

Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
Active UNIX domain sockets (w/o servers)

I have tried to find what I can do to connect to the internet and I have been unsuccessful. I am using a wired connection through a router. I can ping 127.0.0.1 but cannot ping out.

Edit 1

When I open /etc/sysconfig/network-scripts ifcfg-profile_1-1 I get this

TYPE=Ethernet
BOOTPROTO=dhcp
DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=no
NAME="Profile 1"
UUID=d5d3e20c-6ef1-4e11-bf40-0cf5a7c6b463
ONBOOT=yes

Since PEERRDNS=yes what server information am I putting in the /etc/resolve.conf since mine is blank? Also in my network-scripts file I have ifcfg-lo and ifcfg-profile_1 and ifcfg-profile_1-1

Edit 2

When I type sudo dhclient p9p1 -v I get dhclient (2039) is already running -and exiting. this version of USC dhcp is based on the release available on FTP.isc.org. features have been added and other changes have been made to the base software release in order to make it work better with this distribution.

  • Do you have a link on the Ethernet interface? sudo ethtool p9p1 – mattdm Aug 17 '13 at 16:33
  • Yes I do it says link detected: yes. – Ryan Aug 17 '13 at 17:26
1

Seems you are getting no valid IP. Try the following: DHCP Client

To configure a DHCP client manually, modify the /etc/sysconfig/network file to enable networking and the configuration file for each network device in the /etc/sysconfig/network-scripts directory. In this directory, each device should have a configuration file named ifcfg-eth0, where eth0 is the network device name. The /etc/sysconfig/network-scripts/ifcfg-eth0 file should contain the following lines:

DEVICE=eth0 BOOTPROTO=dhcp ONBOOT=yes

A configuration file is needed for each device to be configured to use DHCP. Other options for the network script includes:

DHCP_HOSTNAME — Only use this option if the DHCP server requires the client to specify a hostname before receiving an IP address. (The DHCP server daemon in Fedora does not support this feature.)
PEERDNS=<answer> , where <answer> is one of the following:
    yes — Modify /etc/resolv.conf with information from the server. If using DHCP, then yes is the default.
    no — Do not modify /etc/resolv.conf. 

The reason you can ping 127.0.0.1 it because it is the loopback interface the interface inside your pc.

0

Did you tried to use dhclient?

$ sudo dhclient -v
0

The easiest way would be to use dhclient:

$ sudo dhclient p9p1 -v

If you don't have a DHCP server on your network and you know the IP of you router, you can try to set a static IP:

$ sudo ip addr add 192.168.X.Y/24 dev p9p1
$ sudo ip route add default via 192.168.X.Z
  • When I type sudo dhclient p9p1 -v I get dhclient (2039) is already running -and exiting. this version of USC dhcp is based on the release available on FTP.isc.org. features have been added and other changes have been made to the base software release in order to make it work better with this distribution. – Ryan Aug 17 '13 at 20:14
0

TO CONNECT TO THE INTERNET TRY MANUALLY SETTING THE SETTING MENTIONED BELOW.

From the System menu available at the task bar of your Linux install.

1) Go to: Systems/Preferences/Network/Network Configuration:

Hosts Tab: Select "New" Add /Edit Hosts Entry Box Enter

Address IP:88.88.88.88 Host Name: Firefox.com Aliases: Mozilla.com
Click OK.

DNS Tab: Enter

Host Name: DomainName.Server1

Primary DNS: These remain Blank (Configured Automatically) Secondary DNS: These remain Blank (Configured Automatically)

DNS Search Path:These remain Blank (Configured Automatically)

Hardware Tab: Should be filled in Automatically with your service (Internet Service Provider)

Devices Tab Should be filled in Automatically. Make sure your check-Box's are checked under Profile

Close Network Configuration.

System-Config-Network Box Pops-up Do you want to save changes : Select "Save Changes"

2) Systems/Preferences/Network/Network Proxy:

Location: Default

Auto Proxy Configuration (Select) Autoconfiguration URL: www.Firefox.com

Close

3) Systems/Preferences/Network/Network Connections:

Wired Tab:

Select Add Connection name: Filled Automatically Connect Automatically check box : check

Click Apply. Close Network Connections

4) Systems/Preferences/Startup Programs:

Startup Programs: Click Add

Popup Box: name: Firefox Comment: Mozilla Firefox Click Add Close Startup Application Preferences

Systems/Administration/Firewall: Prompted for your root password.

Services Check Boxes: Check Boxes (x)

DNS IPsec Secure WWW (HTTPS) WWW(HTTP)

Allow access to necessary Services only. Select Apply. Close Firewall Configuration.

5) Systems/Administration/Services:

Service Configuration: Make sure these services are all Enabled.

httpd (APACHE) IP6TABLES IPTABLES sshd sssd Network

Close Service Configuration.

6) Systems/Administration/Authentication: Prompted for root password.

identity & Authentication Tab.

User Account database: LDAP (choose whatever you need.) LDAP Server: idap://127.0.0.1 Authentication method: kerberos password Realm: Firefox.com Check Box: Use DNS to resolve hosts to realms.

Click Apply. Close Authentication Configuration

Advanced Options:

No need to do anything unless you know what you're doing.

NOTE: Although I was able to access the internet (http).

  Error 1) Seems (Https) Secured doesn't want to cooperate (bug ?)
  This   Error 1 changed to....

  Error 2) Server Cannot be found.

Good Luck hope it helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.