I have been trying to burn a few ISOs lately with no success and have certainly used this hardware in the past, so I am not sure what's going on. I am using DVD-R media (tried multiple discs) which appears to be supported by my drive. Here is the error I received in GnomeBaker on Fedora 14 (64):

Executing 'builtin_dd if=/home/tja/Downloads/Torrents/bodhi_0.1.6.iso of=/dev/sr0 obs=32k seek=0'
/dev/sr0: "Current Write Speed" is 1.0x1352KBps.
:-[ WRITE@LBA=0h failed with SK=2h/CANNOT WRITE MEDIUM - INCOMPATIBLE FORMAT]: Wrong medium type
:-( media is not formatted or unsupported.
:-( write failed: Wrong medium type

...and this:

$ cdrecord -prcap
wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits.
Device was not specified. Trying to find an appropriate drive...
Detected CD-R drive: /dev/cdrw
Using /dev/cdrom of unknown capabilities
Device type    : Removable CD-ROM
Version        : 5
Response Format: 2
Capabilities   : 
Vendor_info    : 'Memorex '
Identification : 'DVD+/-DLRWL1 F16'
Revision       : 'BWSB'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.

Drive capabilities, per MMC-3 page 2A:

  Does read CD-R media
  Does write CD-R media
  Does read CD-RW media
  Does write CD-RW media
  Does read DVD-ROM media
  Does read DVD-R media
  Does write DVD-R media
  Does not read DVD-RAM media
  Does not write DVD-RAM media
  Does support test writing

  Does read Mode 2 Form 1 blocks
  Does read Mode 2 Form 2 blocks
  Does read digital audio blocks
  Does restart non-streamed digital audio reads accurately
  Does support Buffer-Underrun-Free recording
  Does read multi-session CDs
  Does read fixed-packet CD media using Method 2
  Does not read CD bar code
  Does read R-W subcode information
  Does not return R-W subcode de-interleaved and error-corrected
  Does read raw P-W subcode data from lead in
  Does return CD media catalog number
  Does return CD ISRC information
  Does support C2 error pointers
  Does not deliver composite A/V data


more info:

$ dvd+rw-mediainfo /dev/sr0
INQUIRY:                [Memorex ][DVD+/-DLRWL1 F16][BWSB]
 Mounted Media:         11h, DVD-R Sequential
 Media ID:              RITEKF1     
 Current Write Speed:   4.0x1385=5540KB/s
 Write Speed #0:        4.0x1385=5540KB/s
 Write Speed #1:        2.0x1385=2770KB/s
 Write Speed #2:        1.0x1385=1385KB/s
 Write Performance:     4.0x1385=5540KB/s@[0 -> 0]
 Speed Descriptor#0:    00/0 R@3.2x1385=4432KB/s W@4.0x1385=5540KB/s
 Speed Descriptor#1:    00/0 R@3.2x1385=4432KB/s W@2.0x1385=2770KB/s
 Speed Descriptor#2:    00/0 R@3.2x1385=4432KB/s W@1.0x1385=1385KB/s
 Media Book Type:       00h, DVD-ROM book [revision 0]
 Legacy lead-out at:    2298496*2KB=4707319808
 Media Book Type:       25h, DVD-R book [revision 5]
 Last border-out at:    2045*2KB=4188160
 Disc status:           blank
 Number of Sessions:    1
 State of Last Session: empty
 "Next" Track:          1
 Number of Tracks:      1
 Track State:           invisible incremental
 Track Start Address:   0*2KB
 Next Writable Address: 0*2KB
 Free Blocks:           2297888*2KB
 Track Size:            2297888*2KB
READ CAPACITY:          0*2048=0

Does anyone have any ideas as to what caused this? I just reinstalled Fedora today (for other reasons) and I am still unable to burn a DVD. I am using Memorex DVD-R discs, and have tried different ones. The drive appears to read media just fine.


  • What does dvd+rw-mediainfo say about the discs? (Under Debian, that utility is in the dvd+rw-tools package.) Mar 5 '11 at 19:04
  • Updated...I noticed that the reported transfer speed is slightly different...1385 vs 1382...not sure if thats an issue. Mar 5 '11 at 19:15
  • So I tried a DVD+R and it worked. Ill report back after I do more digging. Mar 6 '11 at 21:16

You should be able to find out exactly what types of disks your burner will support.

That error message indicates it doesn't support DVD-R (as backed up by your comment that it did work with a DVD+R disk)

As Gilles commented, you should be able to use dvd+rw-mediainfo but failing that, you could look at the physical writer itself.

  • +1 and if my memory serves me well, there was a bug in 'cdrecord' back at the beginning of '11. I remember I switched for a while to crdao (or something similar) to be able to write DVD-R disks. Feb 13 '12 at 21:07
  • 1
    This driver later stopped functioning altogether, but thanks for the answer. Feb 14 '12 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.