0

I installed debian-7.1.0-i386-kde then apt-get install various Xen stuff. After updating Grub I found it boots up using Xen however at the point where it tries to draw my desktop (KDE) I get a bunch of random static colors on screen and it freezes/locks up/crashes.

How do I fix this so I can boot up Xen with Debian as my host OS?

22
  • seems to me you are facing a kernel panic of some sort can you get the end of /var/log/error if you just log in tty and wgetpaste it before ruunning Xorg?
    – vfbsilva
    Commented Aug 16, 2013 at 3:45
  • @vfbsilva which logs do you want to see? heres kern.log pastebin.com/6QcdiDKb search Initializing cgroup subsys cpuset the first is the xen fail the 2nd is non xen boot which loads X and runs fine
    – user4069
    Commented Aug 17, 2013 at 10:04
  • does xen also provide a log?
    – vfbsilva
    Commented Aug 19, 2013 at 18:22
  • @vfbsilva I have the following logs. I don't see a 'xen' one. If it's in a folder i'll need to boot into it to check. ---- alternatives.log aptitude auth.log btmp daemon.log debug dmesg dmesg.0 dmesg.1.gz dmesg.3.gz dmesg.4.gz dpkg.log faillog fontconfig.log kdm.log kdm.log.1 kdm.log.2.gz kern.log lastlog lpr.log mail.err mail.info mail.log mail.warn messages pm-powersave.log syslog syslog.1 syslog.2.gz user.log wtmp Xorg.0.log Xorg.0.log.old
    – user4069
    Commented Aug 20, 2013 at 1:30
  • are you running graphics acceleration of some sort?
    – vfbsilva
    Commented Aug 20, 2013 at 20:11

1 Answer 1

0

Xen is a hypervisor that modify the standard kernel.So many drivers can not work correctly at xen, specially graphics drivers. So you can only start xen at cui model.You can use command line to start virtual machines in xen server.Then you can use another machine to connect a virtual machine to use it. If you want use GUI model in your host,you can use qemu-kvm/virtual-box as hypervisor.Qemu-kvm/virtual-box both use standard kernel,hypervisor is only a driver on host.

You must log in to answer this question.