2

I have installed Linux Mint 15 Cinnamon and I have installed Nvidia drivers using this question. After rebooting the system this message appeared:

Cinnamon just crashed. You are currently running in Fallback Mode. Yes/No

I wasn't able to find solutions about this message appeared after driver installation. Also, since my notebook has two videocards, maybe I should install drivers in some special way.

My notebook configuration:

screenshot

  • 1
    Did your system use Optimus? – Braiam Aug 11 '13 at 16:00
  • I actually don't know. Is there some tool to check it? – franza Aug 11 '13 at 16:59
3

Please add nvidia driver version (use nvidia-xconfig or see nvidia-current package version). I have one idea about what is your problem: Nvidia Optimus - driver that supports it is pretty recent (319.17+) and did not made into Mint/Ubuntu yet so you might need install manually from nvidia.com newer version: http://www.blogsolute.com/install-latest-nvidia-driver-linux-mint/23836/, or use classic bumblebee optirun solution - run graphics heavy applications on NVIDIA (like Left 4 Dead, some games), light on Intel Driver (like cinnamon itself): http://forums.linuxmint.com/viewtopic.php?f=49&t=135283 .

For Mint 15 it is common problem, I had seen earlier posts: search more carefully if you need more help, Optimus is keyword: this thread (http://forums.linuxmint.com/viewtopic.php?f=59&t=136273) might be helpfull too.

  • I looked into /etc/X11/xorg.conf and saw next line: # nvidia-xconfig: version 304.88 (buildmeister@swio-display-x86-rhel47-06) Wed Mar 27 15:32:58 PDT 2013. Is this what you asked? – franza Aug 11 '13 at 17:26
  • Also, if I install drivers manually from nvidia.com, should I then install bumblebee? – franza Aug 11 '13 at 17:32
  • 1
    Yes, 304 is old and have no native support for optimus. Bumblebee is not needed with new drivers from Nvidia.com anymore, so you don't have to. – IBr Aug 11 '13 at 17:36
  • I'm in installation process right now and it asked about the NVIDIA 32-bit compatibility OpenGL libraries. I chose Yes and it says now: The NVIDIA 32-bit compatibility OpenGL libraries are to be installed relative to the top-level prefix (chroot) '/emul/ia32-linux'; however, this directory does not exist. Please consult your distribution's documentation to confirm the correct top-level installation prefix for 32-bit compatibility libraries. Do you wish to install the 32-bit NVIDIA compatibility libraries anyway?. What should I choose? Sorry about all this questions. – franza Aug 11 '13 at 18:17
  • Try yes it should work, hopefully. – IBr Aug 11 '13 at 18:47
2

Nvidia optimus works well using Bumblebee (http://bumblebee-project.org) .Had this problem for a few days ,solved by installing Bumblebee. Run this in terminal

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia

Now Reboot.

0
sudo apt-get remove bumbleblee* primus*
sudo apt-get install nvidia-prime
sudo apt-get install nvidia-settings

reboot

this was helpful for me

0

In case anyone comes through this issue again, in my case I'm using a 940MX on Mint 18.1 64bit and only the driver version 378.13 did the trick for me. Cinnamon doesn't crash anymore with it (whereas it was crashing until 375.x).

Installed and activated through the Driver Manager after adding the https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa repository.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.