I can't play a DVD on my Ubuntu laptop. I've tried VLC. A window with a traffic cone opens and the Drive spins for a short time, then stops. Nothing else happens.


It's usually easier to just install the restricted extras package:

$ sudo apt-get install ubuntu-restricted-extras

If you have any problems the official Ubuntu documentation on playing DVDs has a good troubleshooting guide as well.

The specific steps outlined in @illuminE's answer are from this page as well, mainly:

$ sudo apt-get install libdvdread4
$ sudo /usr/share/doc/libdvdread4/install-css.sh


  • thanks for your suggestion. I'm new to this. I've done what you suggest, the first line got response that libdvdread4 is already the newest version. the s – Felix Aug 11 '13 at 7:31
  • the second line got "Command not found" I'll follow the links and references you give here – Felix Aug 11 '13 at 7:32
  • Is the issue only this movie DVD and does the dvd reader work in general? In the reference slm gave there's information on simply using the Media/open disc/ menu in vlc to disable "DVD menus", and I remember that being useful to me once. Also a package which is installed can sometimes be reinstalled, just to make sure, with the sudo apt-get install --reinstall packagename command. – user44370 Aug 12 '13 at 3:05
  • Wow, that worked for me and I have been at this for 6 hours! Thank you. – Shane Jun 2 '14 at 0:38
  • @Shane - glad it helped you out! – slm Jun 2 '14 at 0:47

Make sure you have the proper codecs and libraries, including libdbdcss2:

sudo apt-get install libdvdread4


sudo /usr/share/doc/libdvdread4/install-css.sh

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.