3

I'm using Debian testing. I want to configure wifi on my netbook, but failed to do so and when the system boots I get the following message:

INFO: task wpa_supplicant:1634 blocked for more than 120 seconds.
"echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.

I have come across info that this is a new feature that informs that a service is failing. The service in my case is /etc/init.d/networking.

The problem is this: Booting process hangs and prints every 120 seconds the message above and that is it. I can't use my netbook any more. Is there any way to boot without this service?

PS. What I'm doing right now is booting from a rescue USB disk to fix the issue but I wonder if there is any boot options I could use in circumstances like this?

  • Does Ctrl-C at that point work? (It should kill that script and move on to the next). – Drav Sloan Aug 10 '13 at 12:49
  • unfortunately no – lord.didger Aug 10 '13 at 13:53
2

I think you have basically following options

  1. disable service from starting up

    $ sudo update-rc.d networking disable
    
  2. disable configuration on boot (by editing /etc/default/networking)

    # Set to 'no' to skip interfaces configuration on boot
    #CONFIGURE_INTERFACES=yes
    
  3. boot to runlevel without it and then after fixing move to desired level

    Debian networking is setup in the S runlevel so this doesn't help that much unless you move the service to a different runlevel. It can be done by using update-rc.d. Then while booting you just have to pass a boot parameter to the kernel saying what runlevel to enter (or updating /etc/inittab modifying default).

    kernel /boot/vmlinuz-2.6.30 root=/dev/sda2 ro 3
    

    You might find following resource useful https://wiki.debian.org/RunLevel. There is also a tool named rcconf for manipulating runlevels and enabling / disabling services.

To me option 2 seems like easiest until you fix your issue.

  • I've found that adding option 'init=/bin/bash' to kernel in grub give me a chance to actually issue these commands even in dire straits like mine. – lord.didger Aug 10 '13 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.