1

I've got two machines with identical Ekiga versions and settings (including accounts), both behind the same router. Both have contacts referencing myself and the standard call back test.

Machine A:

  • Up to date Ubuntu 13.04
  • Connected to wireless network

Machine B:

  • Up to date Arch Linux
  • Connected to wired network

No port forwarding is set up on the router. On machine A, after logging in, my "self" contact shows I'm online and I'm able to successfully complete a call back test with audio and video. After logging out on machine A and logging in on machine B, I do not see myself as online and the call back test just opens the call window for a long time and never calls back. No messages are displayed indicating what is happening. Some debug output:

$ ekiga -d 4 2>&1 | grep STUN | cut -f 3-
                        Ekiga   Started STUN detector
StunDetect...6b8651d700 OPAL    STUN server "stun.ekiga.net" replies Cone NAT, external IP 91.190.8.175
Housekeepe...6b8c0dd700 Ekiga   Stopped STUN detector
                        MonSock Created bundled UDP socket via STUN, internal=192.168.1.3:5060, external=91.190.8.175:5060

I don't get any "PDU is likely too large" messages.

I tried setting up port forwarding to machine B as well. The result is that machine A complains "Ekiga did not manage to configure your network settings automatically", but machine B is still not able to do anything. Despite the warning and the port forwarding setup, machine A is still able to successfully complete a call back test.

The only difference I could find in the two clients is that A has some extra video codecs - H263, H263-1998 and MP4V-ES, to be specific.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.