When I run NetworkManager's applet, nm-applet, on my Scientific Linux 6.4, I get:

[root@computer]# nm-applet

** (nm-applet:4157): WARNING **: bus_init(): Could not get the session bus. Make sure the message bus daemon is running! Message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

An instance of nm-applet is already running.

(nm-applet:4157): GConf-WARNING **: Directory `/system/networking/connections' was not being monitored by GConfClient 0x9cac60

When I pass the command lspci -v I get:

0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
Subsystem: Dell Wireless 1397 WLAN Mini-Card
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at f69fc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [40] Power Management version 3
Capabilities: [58] Vendor Specific Information: Len=78 <?>
Capabilities: [e8] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [d0] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [13c] Virtual Channel
Capabilities: [160] Device Serial Number 18-6d-04-ff-ff-2c-70-1a
Capabilities: [16c] Power Budgeting <?>
Kernel driver in use: b43-pci-bridge
Kernel modules: ssb

How can I fix this problem?

1 Answer 1


Already running?

Do you already have NetworkManager's applet, nm-applet running? You can confirm with this command:

$ pgrep -f nm-applet

If it returns a number, then it's already running and this is that processes PID.


$ pgrep -f nm-applet

When I try and run it a 2nd time as user saml I get the following message:

$ nm-applet 
An instance of nm-applet is already running.

** (nm-applet:32393): WARNING **: <WARN>  constructor(): Couldn't initialize the D-Bus manager.

If I run it as root:

$ nm-applet 
An instance of nm-applet is already running.

Running as root?

It's probably not a good idea to try and run NetworkManager's applet as root. I'd try running it as my normal user account.

What should I do?

For starters I would try restarting the NetworkManager service.

$ sudo service NetworkManager restart

Next I would make sure that the nm-applet wasn't already running prior to trying to run it. Perhaps killing it with this command:

$ pkill nm-applet

Third I'd attempt to use the command line tool, nm-tool, just as a way to confirm that the NetworkManager services is functioning normally.


$ nm-tool |less
NetworkManager Tool

State: connected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            e1000e
  State:             unavailable
  Default:           no
  HW Address:        F1:12:12:2F:7D:4E

    Carrier Detect:  yes

  Wired Properties
    Carrier:         off

- Device: wlan0  [Auto none_of_your_business_3] --------------------------------
  Type:              802.11 WiFi
  Driver:            iwlagn
  • Thanks for the great answer, but I still don't get any icon in the notification and there is no second device, for example your wlan0. Does this mean that my wifi hardware isn't installed? I have a Dell Wireless 1397 WLAN Mini-card. I installed the three Broadcom tools b43-fwcutter, b43-openfwwf and b43-tools through yum. What else should I do?
    – makhlaghi
    Commented Aug 9, 2013 at 10:09
  • @astroboy - yeah if you don't see any wireless devices then yes, the wireless isn't being detected/setup correctly. What does dmesg show for the hardware?
    – slm
    Commented Aug 9, 2013 at 12:13
  • @astroboy - are you logged in as root? Root's not going to be able to send any GUIs to whatever account you're logged into on your laptop without some additional commands. For example if that root shell, try the command xeyes.
    – slm
    Commented Aug 9, 2013 at 12:39
  • When I searched wlan in the dmesg output, I found this line: b43-phy0: Broadcom 4312 WLAN found (core revision 15). It seems the device is found, but I don't understand how it isn't recognized by nm-tool. About being root, I have to say that after your first complete answer, I am not working as root any more.
    – makhlaghi
    Commented Aug 9, 2013 at 16:12
  • According to here: broadcom.com/docs/linux_sta/README.txt , it seems that Broadcom 4312 corresponds to Dell 1395, not Dell 1397. Is their difference this significant? Do you know where I can get the 1397 driver?
    – makhlaghi
    Commented Aug 9, 2013 at 16:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .