4

I'm running Linux Mint 15 Xfce on a Compaq Presario desktop from 2009. I can't seem to get the wifi working. Rather than ask a general question, here's a simple question:

If

$ iwlist wlan0 scanning

returns all the wireless networks available, that means that my wifi card is working?

So, if that's true, then the problem is that I'm just not setting it up properly, isn't that so?

I've tried to configure it using the tools that Mint provides -> Failure. I've tried to configure it the same way I configured my Slackware laptop -> Failure. ( My Slackware config parameters fail on Mint, even though it's the same network)

Looking over 2 or 3 unanswered questions on this site, I can see that others have had similar problems.

So, is it a mistake to try to set up a wireless connection on Mint by configuring files, rather than use their GUI wireless system (which seems not to work properly)? Does anyone know whether the Mint developers have set it up so that the usual Linux/Unix way of doing things is disabled (to make things easier for the user, no doubt).

  • Have you read something along the lines of that very last post in this thread here about NetowrkManager.conf. A wild guess but the cards he lists could be found in a Presario... – user44370 Aug 8 '13 at 23:42
  • Thanks illuniE. I'm currently checking all this out. I already tried one thing suggested in that thread: in my NetworkManager.conf file, I changed 'managed=false' to 'managed=true'. That didn't fix it, but I'm still reading. – bev Aug 9 '13 at 0:40
  • What are you trying to connect to? I had a problem connecting to WPA2 points with Mint default wifi setups. Couldn't resolve it even after working with the NetworkManager.conf file. Hope you can find a solution. – Matt Aug 9 '13 at 6:15
  • Thanks Matt. I'm also trying to connect to a WPA secured ap. Right now I'm going back to the drawing board. I'm going to turn off NetworkManager and try setting it up manually. I've done manual wifi setups before, and I have a feeling that the NetworkManager is screwing it up. – bev Aug 10 '13 at 0:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.