7

I have Ubuntu 10.04 installed as my primary operating system, and I installed PC BSD in a different partition: /dev/sda4 without installing it's boot loader. I figured out that I need to edit /etc/grub.d/40_custom to add an entry for PC-BSD. So far, nothing seems to work, though.

EDIT: this sort of works, but doesn't fully boot the OS, it then asks me for the MOUNTROOT partition.

menuentry "PC-BSD 8.1" {
    insmod ufs2
    set root=(hd0,4)
    kfreebsd /boot/kernel/kernel
}

The selected answer below is correct. If you are dual-booting with Linux I suggest NOT installing the PC-BSD bootloader as the documentation suggests, unless you enjoy pain.

4

this is what I have in /etc/grub.d/40_custom. Works for me :) Just remember to subsitude hd0,3 with your correct entry

menuentry 'FreeBSD 8.0 64bit' --class os {
    set root='(hd0,3)'
    chainloader +1
}
  • 1
    I think that for this to work you need to have the PC-BSD boot loader installed into the PC-BSD partition boot blocks. I sounds like postfuturist does not have the PC-BSD boot loader installed anywhere. If the PC-BSD boot loader can live in the PC-BSD partition boot blocks installing it there will probably get postfuturist up and running. – Rodney Schuler Aug 20 '10 at 14:40
  • In the graphical installer there is a button at the bottom of the disk selection screen titled "Install PC-BSD boot loader": wiki.pcbsd.org/index.php/… . Does this just install the boot loader on the partition, or the MBR of the disk? – postfuturist Aug 21 '10 at 22:02
  • @postfuturist: I don't know, but you can try installing it and restore grub if it is installed on the MBR. Here is the guide for restoring grub wiki.ubuntu.com/Grub2#Recover%20Grub%202%20via%20LiveCD – phunehehe Aug 22 '10 at 16:21
0

There is another solution mentioned here: Add FreeBSD to GRUB2 boot menu, which is:

menuentry "FreeBSD" --class freebsd --class bsd --class os {
 insmod ufs2
 insmod bsd
 set root=(hd0,1)
 kfreebsd /boot/kernel/kernel
 kfreebsd_loadenv /boot/device.hints
 set kFreeBSD.vfs.root.mountfrom=ufs:/dev/ada0s1a
 set kFreeBSD.vfs.root.mountfrom.options=rw
 set kFreeBSD.hw.psm.synaptics_support=1
}

This solution worked for me triple-booting Ubuntu 12.04, LFS 7.9 and FreeBSD 10.3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.