I have tried installing Arch Linux and what I ended up with was a partition scheme like this:

 /dev/sda1  NTFS partition (Windows 7)
 /dev/sda2  ext4 (Arch)
 /dev/sda3  swap

I don't know why, but for some reason I have been unable to mount the NTFS partition under Linux.

It's worth mentioning that the first partition is, for some reason, detected as an EFI partition and as on a GPT-formatted disk (my computer doesn't have an EFI bootloader and the drive has always had an MBR partition table).

I deleted the sda2 and sda3 using the Windows repair disk and was about to install a second Windows 7 installation alongside the first partition, but an error reported that the entire disk is a GPT drive!

The "Used" and "Free space available" sections indicate that the data on the first partition is still there, it's just that I cannot access the actual partition by any means. It seems that the first partition is with an MBR partition table on a GPT style disk.

How do I access the data on the partition?

3 Answers 3


Grab the systemrescuecd Linux distro. Boot with the CD then try mounting the NTFS disk. You might be up a creek without a paddle :(

  • 1
    How about providing a link and some more details?
    – Joseph R.
    Aug 6, 2013 at 21:04

If you have any linux live-cd like Ubuntu around, you could simply boot to that and once you end up on the distro's desktop, simply use the available file manager GUI to see if you can access that windows partition, and ultimately copy important files to a USB drive if you can't restore your access to the partition. If you didn't see your partition in the file manager, you could still try to mount it manually as most of the time the ntfs-3g driver will be loaded(surely there also if you boot that arch linux cd/dvd).

Otherwise, there are many recovery tools, but personally I've had good experiences with Rescatux (Debian-based+lxde). I'd boot it then use the file manager included. Supposedly the disk includes supergrubdisk2 too, which uses grub to try search os installations on the drive.

Finally, and this from my personal experience again, I would backup my data to external storage asap then format/recreate the partition table on the disk and reinstall clean as you can't trust a disk in that state. Good luck!

  • I forgot, if you have an average to good contemporary PC, using a VM goes a long way for experimenting without running into such issues as you describe. For me the lower risk is worth the performance tradeoff!
    – user44370
    Aug 7, 2013 at 2:59
  • I've already tried it to no avail. Mounting the partition is impossible.
    – Onion
    Aug 7, 2013 at 6:46

This is utterly strange, but I have solved my problem.

As I'm not sure what exactly solved the issue, I'll describe what happened.

  • First of all, I tried to access the partition from Arch Linux, which was installed on the same drive. This didn't work;
  • I deleted the Linux partitions;
  • I've unplugged the computer from the electric source and left it overnight (this helped me a few times, especially while fixing recursive fault errors during boot);
  • The next morning I created an Ubuntu LiveUSB, booted the computer from it and mounted the malfunctioning partition using the following command:
sudo mkdir /mnt/disk
sudo mount /dev/sda1 /mnt/disk

After executing the above commands I was able to access the partition and backup all of my files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.