2

I have Windows XP already installed on my HD and I had some space left to install Debian. After I've installed Debian, I answered yes to the Grub bootloader but when booting the computer nothing appears; no menu, only Windows automatically starts.. Why and what to do? This the second install and the problem still occurs. (Windows is new too but always installed first) Debian is still installed now.

Edit1:

-Grub was installed on the MBR of the first hard disk.

-I can access Debian only when bootable usb is plugged in.

Edit2: problem is solved now, by reinstalling -and for the third time Debian- but with a hd image installation method(the previous installations were done by netiso method)-

But still I want to know Why this problem occurs with the netiso method? Why grub is not working when installed with netiso?

5
  • Can you get Debian to boot using the BIOS boot-selection pop up? Or by changing the boot disk in BIOS (maybe from EFI to MBR)? Also, where did you install grub—on the partition, to the MBR, or to an EFI boot partition?
    – derobert
    Aug 6, 2013 at 18:17
  • The easiest way to get Debian to boot without touching BIOS settings is to use the Windows bootloader. See here. Aug 6, 2013 at 18:27
  • Did you by any chance install GRUB in the wrong place? You'd probably want it to go into the MBR of the first hard disk (you say Windows XP, so I'm guessing you aren't running GPT). Other options are for it to be installed into the boot sector or on some completely different media. It's a pretty easy fix, but would probably be nice to know before typing up a full answer whether that's the likely issue here.
    – user
    Aug 6, 2013 at 19:07
  • derobert and MichaelKjörling: Grub was installed on the MBR of the first hard disk. Aug 6, 2013 at 23:33
  • @n.m. I applied the linux boot tip but I couldn't complete it due to some error message: "Checking if "/boot/grub/stage1" exists... yes" shows me a "no" instead.. Aug 6, 2013 at 23:41

1 Answer 1

1

THE WINDOWS WAY

If you have more than one operating system on your computer, you can set the operating system that you want to use as the default one for when you start your computer:

  1. Click Start, click Control Panel, and then double-click System.
  2. On the Advanced tab, under Startup and Recovery, click Settings.
  3. Under System startup, in the Default operating system list, click the operating system that you want to start when you turn on or restart your computer.
  4. Select the Display list of operating systems for check box, and then type the number of seconds for which you want the list displayed before the default operating system starts automatically.

To manually edit the boot options file, click Edit. Microsoft strongly recommends that you do not modify the boot options file (Boot.ini), because doing so may render your computer unusable.

From WineDows Section "Specifying the Default OS for Startup"

It MIGHT find GRUB. But this will help you in starting linux from a primary windows install. Good Luck!

Linux gods forgive me.

1
  • Didn't work, since I only have a single OS on that list: Win XP. Aug 6, 2013 at 23:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.