1

I built emacs 24.3 from source on OS X 10.8 and when I attempt to set the default font with

Options -> Set Default Font -> [font]

My choice is not saved next time I open emacs.

I'm attempting to use misc->6x13

3

That's expected behavior: this menu only changes options for the current instance of Emacs. The Options menu mostly provides quick access to some options that people commonly change mid-session.

To make permanent changes, open the Customize interface from the Options menu. Go to “Emacs” (the toplevel customization dialog), then “Faces”, then “Basic Faces”, and configure the “Default face” item. (This is for Emacs 23, I haven't checked if Emacs 24 has the same structure.) Click on “Set for current session” to test and on “Save for future sessions” when you're satisfied with the values.

1

Alternatively you can set it manually in your ~/.emacs file :

(set-default-font "Menlo")

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.