2

I'm using an old version of OpenSUSE and when I try to update some package via the command line, e.g.

Zypper update firefox

it shows the message listed below.

System management is locked by the application with pid 2181(/usr/sbin/packagekitd).
Close this application before trying again.

2
  • Try using root privileges (su or sudo)
    – Kartik
    Aug 5 '13 at 14:17
  • 1
    Already tried Sudo ,but inspite of root previliges it's showing the same error. Aug 5 '13 at 14:30
1

You already have a Zypper instance running, that's what the error message is telling you. Just kill the other process and try again:

sudo kill 2181

If that doesn't work try

sudo kill -9 2181
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.