Something really dodgy has happened to my installation of Eclipse (version 3.7.2). I don't know if this is an Eclipse issue or some kind of disk corruption issue or what, so I may have used the wrong tags or even the wrong site.

I've used Eclipse before and it's worked fine. But now lots of things are broken. For example: When I open Eclipse it says: "'Indexing help...' has encountered a problem. Errors while indexing". Nearly all the syntax highlighting has gone, but it still underlines unused imports. I had installed icons at the top for Android stuff, but they've now vanished. When I search for something using the panel on the right it says "'Local help' has encountered a problem. An internal error occurred during: \"Local Help\". invalid format:". Basically it's broken in various ways.

I tried reinstalling it, but it didn't help. But there are several Eclipse-related packages, and it's possible that I missed the broken one.

One potentially interesting observation is that even if I uninstall the eclipse package (sudo apt-get purge eclipse), the icon for opening Eclipse is still in the left-hand menu and it still opens in its usual (broken) way. Does this mean that even when it is installed it's somehow not connected to whichever package is supposed to open it?

Any ideas?

1 Answer 1


Sometime eclipse has such problem, if the configuration is broken.

You should delete (after saving it somewhere) your workspace and you should delete your eclipse configuration $HOME/.eclipse/.

After that you should use a fresh install of eclipse with no extra plugins.

(Note: I prefer not to use the Debian-eclipse-packages. Instead you should use the one from eclipse.org)

  • A fresh install of what exactly? Which package(s) should I remove? Aug 4, 2013 at 12:04
  • @DavidKnipe I do not know the current structure of Debian's eclipse packages. I recommenend to purge all packages those names starting with "eclipse" and install then the software directly from eclipse.org.
    – t777
    Aug 4, 2013 at 20:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .