33

I tried to do it with the command startx 1. It seemed to flicker to a different screen momentarily, but then exited. Got the following error:

/usr/bin/xterm: No absolute path found for shell: :1

Any ideas?

42

I think you can do it with this:

$ startx -- :1

Note that you need to be on a text console. If you do this from an X session, you may not be authorized. First Ctrl+Alt+F1 to switch to a text console and log in there.

Press Ctrl+Alt+F7 and Ctrl+Alt+F8 to switch between the X sessions (the F key numbers may vary depending on your distribution).

If you want more control you can add more options to the command like so:

$ startx gnome-session -- :1 vt8

This will start up gnome-session on display :1 and run it on virtual console 8 (Ctrl+Alt+F8).

  • 5
    Ugh, starting an X server with sudo causes everything within the X session to start with root privileges; this even causes some applications to fail. – Brian Peterson Aug 3 '13 at 3:29
  • 1
    @Bepetersn - I was surprised that you said you needed that. What happens without it? – slm Aug 3 '13 at 3:30
  • 5
    @Bepetersn Run this from a text console, not from an X session. On Linux, press Ctrl+Alt+F1 first, log in, and run startx -- :1 from the shell prompt. – Gilles 'SO- stop being evil' Aug 3 '13 at 23:22
  • 2
    @Gilles - thank you for incorporating that into the answer! – slm Aug 3 '13 at 23:47
  • 1
    Sorry, I forgot to respond @slm. If I run startx -- :1 from an X session, the terminal appears unresponsive for a bit, then tells me: xauth: timeout in locking authority file /var/run/gdm3/auth-for-brian-3zy5Hn/database, and fails a bit later with X: user not authorized to run the X server, aborting. During this time, nothing would come up in the 8th tty as you would expect. – Brian Peterson Aug 4 '13 at 6:08
4

I have found that the following way works for me:

sudo xinit /usr/bin/xterm  -e "su peter -c pekwm"  $* -- :1

What happening here?
First I start xinit with an xterm, as a parameter to that xterm I su to become myself. From there I start the window manager.
Only thing you need to do is minimize (not close) the xterm. Probably you could tell the xterm to start minimized—but I have not care enough to find that out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.