I recently installed Arch for the first time in VMWare Workstation 9.0.2, twice (I reinstalled to change some partition sizes). In the first installation I was able to start Openbox instead of X when running startx by copying xinitrc to my /home/user directory, and then simply adding "exec ck-launch-session dbus-launch openbox-session" to the end on both the xinitrc in my user folder as well as the one in /etc/X11/xinit. However, on the second installation, although modifying xinitrc in the same manner as the first time, X starts instead of Openbox after running startx. The end of both xinitrc files look like this:

twm &
xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
exec xterm -geometry 80x66+0+0 -name login
exec ck-launch-session dbus-launch openbox-session

Does anyone know what the issue is?


Consolekit is long deprecated in Arch. Remove the ck-launch-session string from your .xinitrc.

You are also trying to start two window managers, twm and openbox; so remove the twm, xclock and xterm lines as well.

Read the Arch Wiki Openbox article on how to run Openbox as a standalone window manager. Essentially, you only need one line in your .xinitrc

exec openbox-session

and everything else that you want started with your session you include in ~/.config/autostart.

  • Well, that worked. I have no idea why openbox worked along with twm in the previous installation. Thanks for the help. – Nic Aug 2 '13 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.