0

I am running CrunchBang based on Debian 6. I can't do anything printer related. It is saying I am unauthenticated. I have tried:

family@familydesktop:~$ sudo lppasswd -a family
Enter password:
Enter password again:
family@familydesktop:~$ sudo lppasswd -a root
Enter password:
Enter password again:

Yet I still can't add a printer. What do I do?

  • 1
    Can you provide us with the configuration file of cups? /etc/cups/cupsd.conf? – Braiam Jul 31 '13 at 15:39
0

You're most likely not allowing certain types of access to your CUPS daemon. Take a look at the troubleshooting guide:

For example

You'll need entries like this to start:

# /etc/cups/cupsd.conf
# Default authentication type, when authentication is required...
DefaultAuthType Basic
DefaultEncryption Never # comment this line to allow encryption

# Allow access to the server from any machine on the LAN
<Location />
  Order allow,deny
  #Allow localhost
  Allow 192.168.1.* # change to local LAN settings
</Location>

There are other permissions you'll potentially need to grant as well in this file.

0

Try adding yourself to the lp or lpadmin group (whichever exists) or check visudo for print/CUPS related settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.