1

Audio is NOT working in HP workstation xw 4600. I cannot find any hardware present at

System-> Preferences -> Sound -> Hardware (Tab)

The command lspci -v shows following output of Audio Device:

01:00.1 Audio device: nVidia Corporation Device 0bee (rev a1)
    Subsystem: ZOTAC International (MCO) Ltd. Device 5194
    Physical Slot: 2
    Flags: bus master, fast devsel, latency 0, IRQ 5
    Memory at fa000000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: [60] Power Management version 3
    Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [78] Express Endpoint, MSI 00
    Kernel modules: snd-hda-intel

And when I am configuring via alsamixer and press tab F6 [Select Sound Card], there is only one default option is present.

Update 1: The output of the commands shows no hardware present ! is it True?

[root@target ~]# cat /proc/asound/cards   
--- no soundcards ---  
[root@target ~]# rmmod snd-hda-intel; modprobe snd-hda-intel  
ERROR: Module snd_hda_intel does not exist in /proc/modules

Is my hardware NOT properly installed OR I need proper drivers? If so, which?.

Update 2: After reconnecting the hardware and following Gilles instructions, the output is as below:

[root@target ~]# modprobe snd-hda-intel
[root@target ~]# lsmod |grep '^snd_hda_intel'
snd_hda_intel 25771 0
[root@target ~]# uname -rv
2.6.32-71.el6.x86_64 #1 SMP Wed Sep 1 01:33:01 EDT 2010
[root@target ~]#

I still don't know which drivers should I install for proper functioning of this card, please help!

Update 3: Yes, I have tried configuring with alsaconf. But I get following errors:
[root@target ~]# alsaconf
enter image description here
enter image description here
enter image description here

and after this I got following Error Output.

[root@target ~]# alsaconf
ERROR: modinfo: could not find module snd-opl3sa2
ERROR: modinfo: could not find module snd-cs4236
ERROR: modinfo: could not find module snd-cs4232
ERROR: modinfo: could not find module snd-cs4231
ERROR: modinfo: could not find module snd-es18xx
ERROR: modinfo: could not find module snd-es1688
ERROR: modinfo: could not find module snd-sb16
ERROR: modinfo: could not find module snd-sb8
[root@target ~]#

Still NOT getting any hardware information:
enter image description here

  • 1
    So there is no card listed in /proc/asound/cards? Are there any error messages in the system log after you run rmmod snd-hda-intel; modprobe snd-hda-intel? – CL. Jul 31 '13 at 10:12
  • Thanks @CL please check the update. I think the hardware is not properly working! – Tejas Jul 31 '13 at 10:19
  • If the hardware is suspect, it is probably far easier to plug in a known working card and boot that. Sure, this approach lacks elegance but it makes up for it in speed and lack of frustration. – msw Jul 31 '13 at 10:54
  • 1
    Your hardware is detected but you seem to be lacking the proper driver. After running modprobe snd-hda-intel, is the module loaded (check with lsmod |grep '^snd_hda_intel')? What distribution are you running, what version, what kernel (output of uname -rv)? – Gilles Jul 31 '13 at 22:24
  • 1
    Have you ran alsaconf? – n.m. Aug 3 '13 at 7:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.