2

Yesterday I installed Mint 15 MATE on my laptop. Everything worked perfectly, so I installed some packages (python-django, mysql-server, and some other python modules). I also ran apt-get update && apt-get upgrade. Finally I selected a NVIDIA proprietary driver recommended by Mint, and changed the desktop icons.

I did nothing else, and everything worked until today. I powered on the laptop, and the first thing I saw was an "old-fashioned" way of asking for the encryption password at startup, that looks almost like a console, when yesterday was a little Mint logo and a window for the input. After that the login screen appears, and then it freezes.

Sometimes it happens at the login screen (even when I'm typing the password, so it gets stuck when I have written only a few characters), and sometimes I'm fast enough to login and see the desktop, but then it freezes anyway. I guess it's just a matter of time before some module gets loaded.

I can move the mouse, but nothing else works.

What can I do to fix this? I am willing to give you more information if you explain me how. I tried to pause booting sequence to see if there is something wrong (I have been able to see 2 FAILS, one relative to the avahi daemon, but I don't know how to pause the sequence in order to read it).

2

I had also some trouble with my Nvidia Card at boot up and occasionnal freeze. What i've done was to add 'nomodeset' to the grub boot option. You should try it... if it solve the problem you can make the change permanent :

Edit /etc/default/grub

sudo nano /etc/default/grub

Find this line :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Add the 'nomodeset' option :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Update Grub :

sudo update-grub
  • But, how can I do this? I can't login and open a terminal before it gets stuck – Roman Rdgz Jul 30 '13 at 10:28
  • You can try changing it in the grub menu first... hold shift at boot time to show it (if it don't appear by default). – Relic Jul 30 '13 at 10:36
  • Not appearing by default, nor holding shift at boot time. Can I do it through the live cd? – Roman Rdgz Jul 30 '13 at 10:44
  • Yes it's possible via chroot for applying update-grub. But it's a bit complicated. Are you sure holding the shift key doesn't do anything ? – Relic Jul 30 '13 at 11:51
  • Maybe you can switch to a console (CTRL+ALT+F2) before logging to the xsession. – Relic Jul 30 '13 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.