I have the following in my .vimrc

vmap <C-c> y  
imap <C-p> <esc>P  

So that I can do my classic sortcut for copy/paste. It works fine on Cygwin but not in my ssh session to remote linux using a Mac client.

When I press C-c I see X lines yanked but when I press C-p only the first letter of the first line is pasted.

What is the problem?

  • Why in Cygwin there is no issue? Also what is the + for?
    – Jim
    Jul 29, 2013 at 21:08
  • What version of vim are you using in cygwin?
    – slm
    Jul 29, 2013 at 21:15

1 Answer 1


The -t option

 ssh -t

should fix your problem. Here you have a detailed explanation of what happens when working over ssh.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .