I have Fedora 19 running Gnome 3 Shell installed on my laptop, and in a virtual machine running inside VMWare Player on my desktop. The VM has the proprietary VMWare tools and is up to date as of today.

On the laptop I am used to opening the menu by "poking" the corner with the mouse. However I am unable to be able to get it to work in the VM.

I have tried putting the VM to fullscreen and also installing an extension to Gnome that allowed me to configure things like the hot corner threshold. However they did not seem to have any kind of effect.

Is there something in the fact that I run it inside a VM that keeps me from being able to use the hot corner?

2 Answers 2


Partial answer:

I have VirtualBox (not VMWare), but I have the same issue. And moreover, the exact same things happens in remote sessions through VNC.

Probably the problem is that you can't do "pressure" on the hot corner with mouse integration active --- when you try simply you exit from the client windows and go to the host system.

In Virtualbox at least you can disable the mouse integration for the VM; it's a bit of a nuisance because you then have to press the "release" key to leave the windows, but the hot corner will work again.

I hope this can helps with VMware, too. Feel free to edit the answer if it is the case.

  • I haven't tried disabling the integration, but fullscreen did not help. I assumed it would have stayed inside the guest in fs. I'll have to try later
    – varesa
    Dec 17, 2013 at 17:59
  • Yes, you're right. Should work... will check in Virtualbox too as soon as I can. In TightVNC viewer even going full screen the hot corner does not work, though.
    – Rmano
    Dec 17, 2013 at 18:19

Using the Custom Hot Corners - Extended gnome extension and enabling "Use fallback hot corner triggers" in Settings > Options Tab fixed it for me.

See: https://extensions.gnome.org/extension/4167/custom-hot-corners-extended/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .