Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I'm trying to map <c-y>, (from zencoding-vim) to <c-m>.

I tried:

map <C-m> <C-y>,
map <C-m> <C-y>,<cr>

But doesn't seems to be working. Maybe it's something with the comma?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It's not the comma, it's ctrlm which is the terminal control sequence for return and the same as pressing the return key. Try typing ls in your terminal and press ctrlm. You'll run into the same problem trying to map ctrlh, which is the terminal control sequence for backspace.

This is not a Vim issue since Vim can't distinguish between ctrlmand return` key presses.

share|improve this answer
Tried mapping to <C-q> and <C-y> and still the same problem. Maybe I'm missing something else? –  jviotti Jul 26 '13 at 13:43
<C-q> is usually the terminal control sequence for unstop output. <C-s> is to stop output. –  Evan Teitelman Jul 26 '13 at 13:51
@jviotti Try to use the specified mappings imap for insert mode mapping nmap for normal mode mapping, etc. I don't use zencoding and it works here with other mappings. –  Marco Jul 26 '13 at 13:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.