2

I just wiped the hard drive on a desktop computer and used a LiveUSB to install Scientific Linux 6.4, the x86_64 veresion. I went through and simply let the installer use all its default configurations.

Once that was done I tried booting up the machine and I got

Error 1962: No operating system found. 

I'm currently reinstalling it without grub and am going to load grub on manually, but it baffles me that its not working after the simplest installation. Is this a common problem? I've never had this sort of thing happen before.

Update

I attempted to use a dvd instead to install, but it wouldn't boot from the dvd, I plugged the USB in with the dvd and am able to load it now. I'm guessing it must have been missing certain drivers to boot from the dvd. Anyways, the install didn't work from the live dvd either.

  • 2
    Seems very odd; I've installed linux to bare hard drives scores of times (albeit none of them the Scientific distro). Did it actually say it was installing grub at some point? – goldilocks Jul 25 '13 at 19:37
  • Yeah it said it was installing on the first partition, I think that may have been part of the problem. Partition 1 was set as /boot/efi as apposed to just /boot. I'm fairly new to Scientific Linux myself, never really had to deal with efi in the past though, so I'mnot sure what sort of problems it could cause. – Mason Jul 25 '13 at 19:51
  • Did you change the BIOS to boot from the CD-Rom and then not remove the disk when finished? – user8779 Jul 25 '13 at 19:54
  • I'm using a LiveUSB to install it, and the BIOS is set to load from the USB first (which I removed after instillation and shutdown), and then boot as normal. – Mason Jul 25 '13 at 19:57
1

If you have a BIOS (an no UEFI) re-install and ensure that the installer does not set up an efi partition. If it is not hitting grub (you dont' see the menu) the problem is with the handover from the firmware to the bootloader. installing grub to the disk rather than the partition can help with this as well.

I had a similar problem with Centos on my BIOS/UEFI board when trying to install the EFI boot partition. I ended up just using the BIOS boot configuration.

  • I tried configuring the partitions without the /boot/efi but I got a partitioning error which states I must create one to continue. – Mason Jul 25 '13 at 20:14
  • I was having the same issues, I think the problem ended up being the ISO i used was -efi, or something wrong with the USB stick. I ended up getting the vanilla ISO and burning it to disk and worked like a champ. I had to ensure I had Legacy BIOS support enabled in the firmware though. – Luke Jul 25 '13 at 20:58
  • Well I know the ISO file downloaded ok (checksums), but I wasn't paying much attention when I ejected the drive, maybe thats the problem. I'll keep you posted. – Mason Jul 25 '13 at 21:05
  • Didn't work at all. – Mason Jul 26 '13 at 13:44
0

Solution

Don't use liveUSB it simply doesn't work very well if you've wiped the entire computer for some reason. Use liveDVD or better yet the actual install DVD (didn't test that one, but it'd probably work better). If you are using the liveDVD you may have to make an attempt at changing the parameters of the boot up (will get an Error 15). After you enter the editing of the boot properties exit, it'll boot up with the default settings bypassing the previous error.

Don't ask me why that worked, I have no idea, I had just given up when I exited from attempting to change the boot parameters.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.