1

I am trying to use a kickstart file hosted over the network to install Oracle Linux 5.8 (equivalent to RHEL 5.8 I believe). I am using the following at the boot prompt:

linux ks=http://1.2.3.4/my.ks ksdevice=eth0 ip=dhcp

The problem is that at this point, eth0 does not seem to be configured with a driver and I am prompted to select one. Having looked at the various Anaconda docs online, I can't see anything that would let me configure the driver for eth0 from the boot prompt, so that I am not prompted for one afterwards.

Does anyone know of a way to set-up eth0 with a driver from the boot prompt?

1

You need to specify the dd option to kickstart and provide the driver disk locally. See https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/5/html/Installation_Guide/s1-kickstart2-startinginstall.html for the dd option, and https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/5/html/Installation_Guide/s1-kickstart2-options.html for the driverdisk directive inside the kickstart file (you need both, I'm pretty sure).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.