How can I force SSH to request passphrases using a graphical prompt (GTK, for example) instead of the standard one that uses the terminal?

I tried setting SSH_ASKPASS=/usr/bin/ssh-askpass but it seems to have no effects.

The problem is the fact the openssh documentation says

If ssh does not have a terminal associated with it but DISPLAY and SSH_ASKPASS are set, it will execute the program specified by SSH_ASKPASS and open an X11 window to read the passphrase.

An ssh launched from the command line, in my case as the result of a git push, will have a terminal associated with it, so the SSH_ASKPASS logic seems to be ignored.

Please note that I am not referring to ssh-add, but to generic ssh invocations towards an hosts for which a key pair is present but protected by a passphrase.


7 Answers 7


#1 - Missing package?

You're probably missing the package that contains ssh-askpass. Try installing it.


$ sudo yum install openssh-askpass


$ sudo apt-get install ssh-askpass-gnome ssh-askpass

Finding missing utilities

You can search for missing tools using these commands:


$ yum search ssh-askpass
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
======================================================= Matched: ssh-askpass =======================================================
x11-ssh-askpass.x86_64 : A passphrase dialog for X and not only for OpenSSH
ksshaskpass.x86_64 : A KDE version of ssh-askpass with KWallet support
connect-proxy.x86_64 : SSH Proxy command helper
openssh-askpass.x86_64 : A passphrase dialog for OpenSSH and X


$ apt-file -l search ssh-askpass

#2 - Disconnected terminal?

I missed this initially but after further reading up I noticed this comment in the man page of ssh regarding the SSH_ASKPASS environment variable.


SSH_ASKPASS    If ssh needs a passphrase, it will read the passphrase from the 
               current terminal if it was run from a terminal.  If ssh does not
               have a terminal associated with it but DISPLAY and SSH_ASKPASS 
               are set, it will execute the program specified by SSH_ASKPASS 
               and open an X11 window to read the passphrase. This is particularly
               useful when calling ssh from a .xsession or related script.  
               (Note that on some machines it may be necessary to redirect the 
               input from /dev/null to make this work.)

If you notice in the comment, it states that ssh "doesn't have a terminal associated" AND DISPLAY & SSH_ASKPASS are set. Noticing this is key. So to get ssh to use SSH_ASKPASS we need to get ssh to not have a terminal (aka. STDIN & STDOUT) attached to it.

One way to do this by making use of the command setsid. Don't feel bad. I never heard of this tool either. From the man page:

setsid - run a program in a new session

So if we run ssh as the "program" to setsid we can detach ssh from our terminal meeting the criteria mentioned in ssh's man page. The other criteria are set as follows:

$ echo $DISPLAY; echo $SSH_ASKPASS

So if we put this all together:

$ setsid ssh user@remotehost

For example:

$ setsid ssh user@skinner

                                       ss of ask gui

A solution

If you'd like to make it so that the setsid is "built-in" you can create an aliases like so:

$ alias ssh="setsid ssh"

Now when you ssh you'll get the GUI popping up asking for your password:

$ ssh user@skinner


  • ssh-askpass gnome is installed and it works fine if launched manually.
    – gioele
    Commented Jul 22, 2013 at 23:14
  • @gioele - see updates, I think I've figured it out.
    – slm
    Commented Jul 23, 2013 at 1:29
  • the problem of this solution is that it requires that I modify each git or rsync command to use setsid ssh instad of plain ssh.
    – gioele
    Commented Jul 23, 2013 at 8:16
  • @gioele - you asked for a method to "force" the password GUI, this provides that. You can replace commands such as ssh with aliases setsid ssh is one approach. There are other ways. The limiting factor is openssh needs no TTY attached in order to activate the ASK_SSHPASS.
    – slm
    Commented Jul 23, 2013 at 9:08
  • 1
    I'm not missing the package and I cannot use setsid and then work in ssh from my terminal. That's just not a valid answer at all!? Plus, it was working in older versions of Ubuntu, so I'm not too sure I understand why it suddenly stopped working! Commented Nov 30, 2014 at 5:40

It only took 19 years to solve this issue OpenSSH Bug 69 - generalised-askpass.

OpenSSH 8.4 will include a $SSH_ASKPASS_REQUIRE variable that accepts force|prefer|never options.

When I set SSH_ASKPASS_REQUIRE to prefer then ssh-add from the terminal will launch the ssh-askpass user interface. On my Arch Linux machine I have the following in my .xinitrc

export SSH_ASKPASS=/usr/lib/ssh/x11-ssh-askpass
eval `keychain --eval --noask ~/.ssh/id_rsa`

And in my ~/.ssh/config I have

AddKeysToAgent yes

So when I run e.g. git pull in one of my projects the very first time after a reboot, then the askpass dialog will correctly popup and ask for the password only a single time.

Hope that helps.


It cannot be done in OpenSSH before version 8.4: for details read the issue in the OpenSSH Bugzilla asking for this feature since 2002 and finally fixed in 2021-01: Generalize SSH_ASKPASS.

For OpenSSH version 8.4+, see the accepted answer for a quick explanation of how to achieve this using SSH_ASKPASS_REQUIRE.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post.
    – cuonglm
    Commented Oct 13, 2015 at 1:30
  • 10
    @cuonglm "this is not possible" is an answer. It might be wrong or misleading (I'm not saying it is), but it's still an answer.
    – terdon
    Commented Oct 22, 2015 at 14:04
  • Correct, the "it cannot be done" assertion saves us from searching the web for an answer that isn't there.
    – Coder Guy
    Commented Nov 11, 2021 at 21:14

There is a way to close the terminal for a single command, and that is using file redirection:

ssh-add > /dev/null < /dev/null 2>&1

This will run the command ssh-add with the terminal closed. Which is fine and dandy, except for the its complexity. But now that you know the correct command, simply make it an alias and append it to ~/.bash_aliases:

alias ssh-add="/usr/bin/ssh-add > /dev/null < /dev/null 2>&1"

And you should be set. Simply typing ssh-add will now invoke the alias which will invoke the real command with all the redirection in place.

The ssh-add now correctly asks you the password with a dialog box... Provided that you have one of these packages installed (in Ubuntu or derivatives, they may have other names elsewhere):

  • ssh-askpass
  • ssh-askpass-fullscreen
  • ssh-askpass-gnome
  • ksshaskpath
  • kwalletcli
  • lxqt-openssh-askpass
  • razorqt-openssh-askpasss

Now, what do all those things mean?

The 2>&1 means redirect file descriptor #2 (standard error) to the same place file descriptor #1 (standard output) is directed to.

The > /dev/null means redirect standard output to /dev/null, which is a special file that discards all data written to it.

The < /dev/null means redirect standard input to /dev/null (idem).

As a side note, and an off topic but related note, if you ever want to program a service in bash, you must remember what a service actually is, a process with standard input, output, and error closed that is in the background:

service > /dev/null < /dev/null 2>&1 &

Notice that the only difference is the & added at the end (plus the fact that I changed the command ssh-add for a theoretical service. Those commands will correctly put a service on the background.

  • Thank you for the detailed answer Victor. However, it does not fit my requirements. As I wrote at the end of the question, «Please note that I am not referring to ssh-add, but to generic ssh invocations towards an hosts for which a key pair is present but protected by a passphrase.».
    – gioele
    Commented Mar 20, 2017 at 6:23
  • I see. Well, ssh functions the exact same way, and the same answer I gave previously still applies. Just replace every occurence of ssh-add with ssh and you are set.
    – Victor
    Commented Mar 22, 2017 at 14:38
  • There is just a tiny detail you forgot: if I close stdin/stdout for ssh, how do I give commands through ssh? ;)
    – gioele
    Commented Mar 22, 2017 at 15:54
  • This worked for ssh-add for me - I didn't even need to redirect stdout/stderr to get the desired behavior, which was to pop up the ssh-askpass program. (That is, ssh-add < /dev/null was enough.)
    – Ben Stern
    Commented Apr 19, 2019 at 0:50

I had the same problem when I installed seahorse (which provide seahorse-ssh-askpass) without installing the package gnome-keyring on ArchLinux.

Looking at the content of this package gnome-keyring (https://www.archlinux.org/packages/extra/i686/gnome-keyring) may help you solve your problem.

In any case, if you do not mind using seahorse, you can also install the packages seahorse and gnome-keyring (or the equivalent ones for your distribution). If you do not use Gnome, additional steps may be required: https://wiki.archlinux.org/index.php/GNOME_Keyring.

  • I agree that this is an effective solution. It doesn't force the use specifically of the ssh-askpass command, but it does provide a graphical prompt the first time a key is needed. It provides it's own socket at $SSH_AUTH_SOCK (typiically under /run/user/NNNNN/keyring/ssh-sock) which acts like an ssh-agent. Commented Apr 24, 2022 at 4:34

As of Debian 12, I followed part of the answer by @thg, and it's working as expected.

First, the installation of ksshaskpass already sets /usr/bin/ssh-askpass to be /usr/bin/ksshaskpass

Therefore, there's no need to set SSH_ASKPASS explicitly.

Second, the recommended routine to add a public key to github.com or gitlab.com already enables the SSH agent. And there's no need of adding the public key to the keychain.

Therefore, all I had to do was to add the line


to the .profile file, and to include the line

AddKeysToAgent yes

to the config file in the .ssh folder.

Thanks to @thg and thanks to the evolution of SSH and Debian.


In my opinion, the simplest solution is to set the pinentry program of your choice using update-alternatives. For example for KDE this would be:

# review current default pinentry for ssh-askpass
update-alternatives --list ssh-askpass

# set
update-alternatives --force --verbose --set ssh-askpass /usr/bin/kssaskpass

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .