5

I'm using OpenSuse 12.2 x64. I have tried this in /etc/fstab:

//192.168.6.80/shared/folder1 /mnt/folder1 cifs rw,user=guest,password=,uid=1000 0 0
//192.168.6.80/shared/folder2 /mnt/folder2 cifs rw,user=guest,password=,uid=1000 0 0

After rebooting, if I access the first folder cd /mnt/folder1 and list files ls, my shared files are listed. If I try accessing folder2, nothing is listed.

If I reboot and try again, but this time accessing folder2 first, the files are listed. After, accessing folder1 nothing is listed.

In other words, it mounts just the first accessed folder. Mounting it manually, mount -all, the two folders are mounted, but I need it to be mounted automatically at boot because these folders are used in services.

How do I mount more than one shared folder using /etc/fstab at boot?

3

Try modifying your boot options in your commands so they include the _netdev option:

//192.168.6.80/shared/folder1 /mnt/folder1 cifs _netdev,rw,user=guest,password=,uid=1000 0 0
//192.168.6.80/shared/folder2 /mnt/folder2 cifs _netdev,rw,user=guest,password=,uid=1000 0 0

Per this thread that I found titled: CIFS share in /etc/fstab doesn't automatically mount.

References

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.