2

I'm trying to mount the Windows Share on one of Our Redhat 5.9 Server. I use this command

mount -t cifs //hostIP/Folder /share2 -o username=alpha,password=blahblahblah

And

mount.cifs //hostIP/sales /share2 -o username=alpha,password=blahblahblah,domain=ourdomain.corp

But whatever I do it always gives me permission denied error

mount error 13 = Permission denied
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
2

Also try the option sec=ntlm. Depending on the version of mount.cifs that option might be necessary to mount Windows shares.

mount -t cifs //hostIP/Folder /share2 -o sec=ntlm,username=alpha,password=blahblahblah
0

Are user and permissions set correctly on the Windows share? Is it possible to access this share from another Windows box with the credentials you provide in your options? Try

mount.cifs //hostIP/sales /share2 -o username=alpha,password=blahblahblah,domain=ourdomain.corp --verbose<br/>

to get more information.

  • Well I tried this but it didnt give me much information. Message was mount.cifs kernel mount options: unc=//HOST-IP\SHARENAME,ip=HOSTIP,ver=1,rw,sec=ntlm,username=WindowsServerUsername,password=WindowsServerpassword. – OmiPenguin Jul 21 '13 at 7:35
0

I was also having this problem, part of the fix was to fully upgrade SAMBA

samba-client-3.0.33-3.41.el5_11
samba-common-3.0.33-3.41.el5_11

These versions are newer than the version that shipped with RHEL5.9 and include rolled back patches for bugs from 2013

The part that still isn't working is mounting the share from a Domain attached 2008r2 server. If the server is not domain attached the mount works fine. I suspect that there is a GPO on the server for not accepting connections from hosts that can do a certain level of security signing. RHEL 5x doesn't seem to support NTLMv2 for instance.

0

This is a problem with the kernel mounting.

https://access.redhat.com/solutions/2488681

They basically say that until kernel-3.10.0-514.6.1.el7 comes out that you will need root fileshare permissions on Windows to be able to mount to the children folders.

0

On RHEL 5.9, the CIFS client module is definitely using SMB protocol version 1.0 by default. A well-maintained Windows server will most likely be configured to reject the versio 1.0 because of security weaknesses by now.

Add mount option vers=2.0 to the mount command to use SMB protocol version 2.0, which was introduced with Windows Server 2008.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.