2

I'm testing a bluetooth application running on an Android device. I registered a dummy service on the device and opened the RFCOMM channels to it from the PC running Ubuntu 12.04:

bluez-test-serial 7C:E9:D3:DE:03:0A 43502780-ef1e-11e2-b778-0800200c9a66

It spawns /dev/rfcomm0 alright, but immediately after I'm catching channel input on the device side. It reads AT+GC. Surprisingly, it seems to happen only the first time after I login.

I grepped through the BlueZ sources to no avail.

Does anybody know what could be the source of this unsolicited AT command being fed into the channel?

1
  • 2
    AT+GC belongs to the V.250 AT+G series which is Generic issues such as identity and capabilities. So without knowing the exact meaning of the command, it's probably trying to identify the modem or its capabilities. I don't know anything about what might be issuing it, but maybe that'll help you track it down.
    – user
    Jul 18, 2013 at 8:04

2 Answers 2

2

The program sending it is modem-manager. I ran into this issue with it too. I never figured out how to make it ignore my device, so I just uninstalled the program. Not sure if that is an acceptable solution for you or not.

1
0

This is a very old question, but in case anyone ends up here via Google, a straightforward solution that worked for me was to create a file /etc/udev/rules.d/99-rfcomm.rules with the following content:

# ignore rfcomm0 device for now
KERNEL=="rfcomm0", ENV{ID_MM_DEVICE_IGNORE}="1"

ModemManager will ignore the device in the future. Note: this is a catch-all rule that will match any rfcomm device, so if you actually want to use one as a modem in the future, you would have to disable the rule again.

1
  • 1
    Or move that rule to 98 and make a new 99 that re-enables MM. Nov 12, 2017 at 14:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .