3

According to the man pages, yum list extras performs the following action:

$ yum list extras [glob_exp1] [...] List the packages installed on the system that are not available in any yum repository listed in the config file.

According to another web page, yum list extras performs the following:

Show all packages not available via subscribed channels or repositories i.e show packages installed via other repos:

http://www.cyberciti.biz/faq/rhel-centos-fedora-linux-yum-command-howto/

When I run yum list extras all the packages come from either base, or updates. Those seem like pretty standard repo locations to me.

[root@mongo-test3 ~]# yum list extras |tail
smartmontools.x86_64                    1:5.42-2.el6                @base/6.3   
sos.noarch                              2.2-29.el6                  @base/6.3   
strace.x86_64                           4.5.19-1.11.el6_3.2         @updates/6.3
systemtap-runtime.x86_64                1.7-5.el6_3.1               @updates/6.3
tar.x86_64                              2:1.23-7.el6                @base/6.3   
tcsh.x86_64                             6.17-19.el6_2               @base/6.3   
udev.x86_64                             147-2.42.el6                @updates/6.3
util-linux-ng.x86_64                    2.17.2-12.7.el6_3           @updates/6.3
virt-what.x86_64                        1.11-1.1.el6                @base/6.3   
yum.noarch                              3.2.29-30.el6.centos        @base/6.3 

I've even tried the following. It still is not clear to me what qualifies as extras

[root@mongo-test3 ~]# yum list > /tmp/yum_list.txt
[root@mongo-test3 ~]# yum list extras > /tmp/yum_list_extras.txt

$ vimdiff /tmp/yum_list.txt /tmp/yum_list_extras.txt ss of vimdiff

Update #1:

Version
CentOS 6.4

[root@mongo-test3 tmp]# ls /etc/yum.repos.d/
10gen.repo  centos-base.repo  epel.repo  epel-testing.repo  puppetlabs.repo
[root@mongo-test3 tmp]# uname -a

Linux mongo-test3 2.6.32-279.22.1.el6.x86_64 #1 SMP Wed Feb 6 03:10:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
2

When I run yum list extras I get a list of only those packages which aren't installed via RHN Satellite or an established repo:

# yum list extras
Loaded plugins: kmod, rhnplugin
This system is receiving updates from RHN Classic or RHN Satellite.
Extra Packages
MQSeriesClient.x86_64                      7.0.1-5                       installed
MQSeriesJava.x86_64                        7.0.1-5                       installed
MQSeriesRuntime.x86_64                     7.0.1-5                       installed
MQSeriesSDK.x86_64                         7.0.1-5                       installed
MQSeriesSamples.x86_64                     7.0.1-5                       installed
ca-cs-cam.noarch                           13.0.10-7                     installed
ca-cs-utils.noarch                         11.2.11350.0-0000             installed
gsk7bas.i386                               7.0-3.18                      installed
gsk7bas64.x86_64                           7.0-3.18                      installed
rhn-org-trusted-ssl-cert.noarch            1.0-2                         installed

What flavor / release are you running? I'm in RHEL 5.9.

  • I updated the description. It is Cent 6.4, running inside an openstack instance – spuder Jul 17 '13 at 17:32
  • It would seem that openstack has changed the behavior of yum list extras - running it on RHEL 6.4, I get the behavior exactly as described in the man pages, not the behavior you're seeing. – John Jul 17 '13 at 17:34
  • I checked another openstack instance and found the same behavior. Even though only base and epel6 were loaded, almost every package showed up as an extra. I tried a bare metal install of cent 6.4, and found the correct behavior you described. – spuder Jul 17 '13 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.