162

I have a program that is installed in a custom directory under /opt. To make it easier to run it, I edited my bashrc to add said directory to my path:

export PATH=$PATH:/opt/godi/bin:/opt/godi/sbin

This works fine if I want to run the program without sudo. However, if I try to run it with sudo it fails with a "command not found" error.

$ sudo godi_console
sudo: godi_console: command not found

Inspecting the PATH variable after using sudo reveals that its not including the same PATH I have as a normal user:

$ sudo sh
# echo $PATH                 
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

Why is the PATH not the same? Am I doing something wrong? I'm on Debian Jessie, if it makes a difference.

One thing I tried was to invoke /opt/godi/sbin/godi_console directly, passing the absolute path to the executable. Unfortunatelly, that didn't help in this particular case because godi_console itself depends on the PATH being correctly set.

5
203

You can always do:

sudo env "PATH=$PATH" godi_console

As a security measure on Debian, /etc/sudoers has the secure_path option set to a safe value.

Note that:

sudo "PATH=$PATH" godi_console

Where sudo treats leading arguments containing = characters as environment variable assignments by itself, would also work at running godi_console with your $PATH (as opposed to the secure_path) in its environment, but would not affect sudo's search path for executable, so wouldn't help sudo in finding that godi_console.

7
  • 5
    I like this answer best since it avoids need to change settings globally (i.e. preserves principle of least privilege) – Alois Mahdal Mar 11 '15 at 0:31
  • 6
    sudo "PATH=$PATH" godi_console did not work in CentOs7 by the way. Needed the env – Hakan Baba Jan 25 '18 at 6:29
  • 1
    Is it okay to use sudo env "PATH=$PATH" as an alias for sudo? What kind of problems could this create? – derricw Apr 12 '18 at 16:22
  • 2
    @ballsatballsdotballs. As that alias should only affect your interactive shells, that should be relatively harmless. – Stéphane Chazelas Apr 15 '18 at 13:43
  • 2
    I just create an alias called psudo for these types of cases, where: alias psudo="sudo env \"PATH=$PATH\"". Then my normal sudo use is unaffected. – mikeTronix May 18 '18 at 18:38
55

You can also set the default PATH at /etc/sudoers

edit the file using visudo

and update the line to what ever you wish: Defaults secure_path = /sbin:/bin:/usr/sbin:/usr/bin

1
26

SUDO is doing env variables reset by default.

Check out its manual and option called env_reset.

You just need to disable it in /etc/sudoers.

3
  • 7
    Cool! In Ubuntu you can visudo and comment out the secure_path and env_reset lines. Makes the system considerably less secure, so beware. – RawwrBag Mar 29 '16 at 18:29
  • Disabling env_reset seems not to affect sudo's behaviour w/r/t PATH. – Zanna Apr 13 '18 at 11:40
  • 1
    You have to comment secure_path as well, as mentioned by @RawwrBag – Prateek Joshi Dec 21 '19 at 6:18
9

This works :

sudo $(which your_command)

Example calling my gps script which lists Nvidia GPU's processes :

$ sudo gps
sudo: gps: command not found
$ sudo $(which gps)
  PID TTY          TIME CMD
 9922 tty7     02:42:47 Xorg

Explanation :

$ set -x;sudo $(which gps);set +x
++ which gps
+ sudo /home/xyztuv/myScripts/shl/gps
  PID TTY          TIME CMD
 9922 tty7     02:42:39 Xorg
+ set +x
1
  • 1
    This is the best answer because it doesn't expose you to other commands on your path being hijacked. All of the other answers here risk running other executables as root. – Jim Hunziker Jan 14 at 14:08
4
sudo --preserve-env=PATH env [command]

this ovverrides secure_path on my end

1

This worked:

sudo "PATH=$PATH" [your command]

Do not change $PATH with your path value, you just write it this way

example: $ sudo env "PATH=$PATH" ant -f webAppConfig.xml regenWebAppConf....

1

Here's what worked for me on Ubuntu.

Put this near the bottom of your ~/.bashrc:

mysudo() {
        cmd=$(which $1)
        shift
        sudo "$cmd" $@
}

alias sudo="mysudo"

Then log out and log back in, or do:

source ~/.bashrc

After that sudo works properly, like it does on other distros such as Debian.

On second thought, this is not supporting sudo's command line switches, so if you need those, you could expand on this and make something a bit more complex to support it.

0

Maybe not precisely what OP asks for, but this might help:

sudo -u the_user sh -c 'PATH=$PATH:/opt/godi/bin echo $PATH'

This changes the PATH inside the sudoed command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.