Let me preface this by saying I'm not experienced in any of this. I followed the in-depth beginners guide for installing Arch using VirtualBox.

I was able to install Arch just fine. After everything was installed I was able to ping different websites so it looked like the internet was working, not to mention I was able to download packages just fine from the internet with pacman. I then went to install Xfce because I heard it is a nice desktop environment. I think I also installed some stuff to do with VirtualBox Guest Additions (not really sure what they are). I was able to install that just fine, and rebooted my machine. After I logged in with my new desktop, I found that I have no internet. I searched around all last night and nobody seems to have my issue. From the "Network Configuration" page, it simply says to try pinging a website like so:

ping -c 3 google.com

Which fails with "unknown host google.com". If that fails, it says to do so like this:

ping -c 3

But that fails for me saying the network is unreachable. The website does not say what else to do in this case. I'm just completely lost on what to try next.

edit: Also, I tried some sort of pacman -Syu command last night because the guide I was using said to do that for the Guest Additions stuff. Could that have contributed to this problem?

edit: So not even a few minutes after posting this I tried just running dhcpcd in the terminal and I have internet again (at least ping works now). How do I make it do that when I boot up?

  • 1
    You need to enable the dhcpcd service. Read the Arch Wiki page on networking...
    – jasonwryan
    Commented Jul 16, 2013 at 0:24

1 Answer 1


You need to check which interface you are using by typing

# ifconfig

(look for names like eth0, eth1, wlan0, wan0 etc)

Afterwards you can add the dhcpd service at boot by issueing

# systemctl enable dhcpcd@<interface>

the interface is often eth0, so if you are unsure you can just try this. To disable running this at boot you can disable it with

# systemctl disable dhcpcd@<interface>


  • 1
    Upvoted, but ifconfig has been deprecated in favour of ip.
    – jasonwryan
    Commented Jul 16, 2013 at 5:41
  • thanks for adding that, I wasn't aware that the good old ipconfig is deprecated in arch linux.
    – superuser0
    Commented Jul 16, 2013 at 5:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .