3

I've installed CentOS6 on my laptop, which has a built in VGA and a discrete (AMD) VGA.

I used to switch AMD video off in other distro's (e.g. Fedora, Arch) using:

$ echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

Because when both are running my battery drains quickly and the temperature rises. However in CentOS I can't find the vgaswitcheroo folder under /sys/kernel.

How can I disable my AMD video device like I did before?

Here's my lsmod | grep radeon :

radeon                917108  0 
ttm                    80957  1 radeon
drm_kms_helper         40087  2 i915,radeon
drm                   265638  5 i915,radeon,ttm,drm_kms_helper
i2c_algo_bit            5935  2 i915,radeon
i2c_core               31084  7 videodev,i2c_i801,i915,radeon,drm_kms_helper,drm,i2c_algo_bit

And lsmod | grep -i intel:

snd_hda_intel          27823  4 
snd_hda_codec         121518  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
snd_pcm                86635  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd                    69907  16 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
snd_page_alloc          8470  2 snd_hda_intel,snd_pcm

I have AMD Radeon 7670M VGA card so i have no idea whether if these are the right modules or not.

Here's dmesg | grep -i switcheroo:

VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle
vga_switcheroo: enabled

Any help would be appreciated.

1 Answer 1

1

Even though this page is on the ArchLinux wiki there are still a couple of things on it that might be worth trying on your CentOS6 system.

This fedoraforums.org thread titled: VGA switcheroo problem also had some good leads of things to try.

In general I would suspect that the absence of vgaswitcheroo has to do with a driver (kernel module) either being loaded or not loaded. I would confirm that you're using the correct drivers first. The reason I say this is because of this comment in that thread:

So, the lesson of my story, if you can't see the vgaswitcheroo directory, then perhaps one of the first things to check is whether you actually have two video drivers loaded. lsmod is your friend.

3
  • I've edited my question to include lsmod result. Please take a look at it. Thanks. Jul 14, 2013 at 2:10
  • @RafaelAdel - the intel drivers are for sound (I have the same ones). The radeon drivers looks right.
    – slm
    Jul 15, 2013 at 7:12
  • @RafaelAdel - can you please provide output to lspci?
    – slm
    Jul 15, 2013 at 7:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .