1

I am using Cygwin to connect to an Ubuntu installation, and for some reasons my Ctrlh for the help has been remapped to CtrlDel.

When I actually type Ctrlc,h I get the error:

No operation mapped for Ctrl + c <DEL>.

There was a key mapping for ctrl + h to ctrl + delete in the init.el, now I have deleted it but still ctrl + h acts as a ctrl + DEL.

How can I reset this?

  • What terminal are you using on the Windows machine? E.g. rxvt under X, xterm under X, standalone rxvt, standalone mintty, native Windows console, Console2, … – Gilles 'SO- stop being evil' Jul 13 '13 at 22:28
  • I'm with Gilles, it's probably a setting in the application you are using to connect, rather than in Cygwin itself, or Ubuntu, or Emacs. – tripleee Jul 14 '13 at 6:32
  • I am using Cygwin and I am connecting through ssh – Edmondo1984 Jul 14 '13 at 7:15
2

Your C-h key is mapped to C-DEL. Try this:

(define-key key-translation-map [?\C-h] [?\C-?])

Or you can change your terminal so it sends C-DEL (aka C-?) instead of C-h for the Backspace key. To do that:

stty erase '^?'

More information here:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.