7

I want to try this VAAPI backend for VDPAU. I have compiled mplayer with vdpau in Gentoo Linux (amd64) but I get this error:

Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[vdpau] Error when calling vdp_device_create_x11: 1 

The same error appears when I run vdpauinfo. The library seems to be linked:

$ ldd /usr/bin/mplayer | grep vdpau
    libvdpau.so.1 => /usr/lib64/libvdpau.so.1 (0x00007f8242fda000) 

And libraries exist:

$ ls -l /usr/lib64/libvdpau.so*
lrwxrwxrwx 1 root root    17 jul  8 22:24 /usr/lib64/libvdpau.so -> libvdpau.so.1.0.0
lrwxrwxrwx 1 root root    17 jul  8 22:24 /usr/lib64/libvdpau.so.1 -> libvdpau.so.1.0.0
-rwxr-xr-x 1 root root 14560 jul  8 22:24 /usr/lib64/libvdpau.so.1.0.0 
$ ls -l /usr/lib64/vdpau/
total 156
lrwxrwxrwx 1 root root     23 jul  8 22:24 libvdpau_trace.so -> libvdpau_trace.so.1.0.0
lrwxrwxrwx 1 root root     23 jul  8 22:24 libvdpau_trace.so.1 -> libvdpau_trace.so.1.0.0
-rwxr-xr-x 1 root root  51032 jul  8 22:24 libvdpau_trace.so.1.0.0
lrwxrwxrwx 1 root root     19 jul 12 21:34 libvdpau_va_gl.so -> libvdpau_va_gl.so.1
-rwxr-xr-x 1 root root 105360 jul 12 21:34 libvdpau_va_gl.so.1
2
  • The reason the linkage is not obvious may be because it is libvdpau.so (not mplayer) which relies on libvdpau_nvidia.so.
    – goldilocks
    Jul 13, 2013 at 13:01
  • This may be useful to others - I had this error on Debian 8 - it was preventing VLC image from displaying (though sound was still working). Rebooting fixed it. Aug 14, 2016 at 7:17

1 Answer 1

1

The issue is with libvdpau_nvidia.so missing. I found this Q&A on askubuntu titled: GNOME Mplayer: “Failed to open VDPAU backend libvdpau_nvidia.so” error. There were 2 fixes identified in this question.

  1. link nvidia to libvdpau

    $ ln -s /usr/lib/vdpau/libvdpau_nvidia.so.1 /usr/lib/libvdpau_nvidia.so
    
  2. use a different codec

    $ mplayer -vo xv video.wmv
    
4
  • 1
    Neither is useful. 1# I think is not valid because I have no libvdpau_nvidia.so in /usr/lib/vdpau, as you can see in my question. So do you need NVIDIA drivers to use the VDPAU API?. 2# has no sense, because xv driver has not hardware support for H.264 or MPEG video decoding.
    – Jaime M.
    Jul 15, 2013 at 6:40
  • @el_Salmon Yes, you need the NVIDIA drivers.
    – derobert
    Nov 12, 2013 at 22:37
  • 1
    Actually, other manufacturers have started releasing VDPAU-compatible drivers (but of course you still need one). The generic libvdpau is only a wrapper around your driver's implementation. en.wikipedia.org/wiki/VDPAU
    – fkraiem
    Mar 9, 2014 at 21:08
  • 1
    It's not answering your original question, but I'm guessing that because you're trying to use a VDPAU driver with a VA-API backend, you may find this useful (particularly the section about MPlayer). libvdpau is also hardcoded to load the NVidia driver according to this link.
    – mjturner
    Jul 21, 2015 at 15:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .