While surfing with Iceweasel, I tried typing in a Web address, but I found, that every few keys, it started typing other letters instead of the ones I typed. For example, if I typed "c-c-c-c-c-c-c-c-c-c-c-c" it printed "ckexccccckex" or if I typed "a-b-c-d-e-f-g-h-j-i", it printed "abckexghi" instead.

  • Each time this occurs, the misplaced letters are different, but always in some pattern. Sometimes, it places backspaces or spaces, not just letters.
  • When I did not type anything, no words appeared.
  • When I unplugged and replugged the USB keyboard, it still had the problem.
  • The problem only appears in Iceweasel, in the URL bar or in text fields, but not in other applications.
  • The problem went away after closing Iceweasel and reopening it.
  • I can find no pattern in when it appears.

How can I determine the cause? Could this be the result of a security issue?

I am using Debian 7.0 with a Logitech K120 keyboard.

  • Obviously it shouldn't happen. I wouldn't consider malware a likely cause: why would malware do this? (It could be buggy malware, of course.) It's impossible to tell the cause without more investigation. Did it happen only in Iceweasel or also in other programs? Did it also happen on text consoles? Did abnormal behavior start on keys other than C? Do a memory test, just in case. Jul 13, 2013 at 20:30
  • To run a memory test, install the memtest86+ package, reboot, and select “Memory test” at the Grub/Lilo/… prompt. Let it run for at least one full pass (e.g. overnight). Jul 14, 2013 at 0:04
  • 3
    Send the keyboard back to the NSA :) Jan 26, 2014 at 13:55
  • Probably a bad keyboard.
    – Keith
    Jan 28, 2014 at 12:10
  • Can it be the keyboard's problem, if the problem only occurs in one application, Iceweasel, but not in other applications?
    – Village
    Jan 28, 2014 at 12:18

3 Answers 3


I cannot tell you why your keyboard does that but I can tell you about similar (not identical, just similar) experiences that I and others have had.

I have two systems on which the keyboard works right almost all the time. At random intervals (sometimes once a week, sometimes several times an hour), several keys that I type will be lost. At other times, strange keys will be inserted.

In all cases, when such a glitch happens, the keyboard LEDs (numlock, etc.) will flash.

I had thought it might be a bad wire causing a power fluctuation and therefore keyboard MCU reboot. But there are many other possibilities. I found, for example, on AskUbuntu this somewhat similar question about keyboard and mouse problems. In one of the answers there, John Siu speculates:

There are multiple possibilities and I cannot be sure. I will list the most probable causes to my knowledge: (1) Pure software: Linux driver is not handling the 1.1 port correctly for this chipset. This will be the most possible cause. (2) Partial hardware: USB port are sensitive to static and can degrade/die over time, especially for older motherboard and chipset. Your 1.1 port maybe degrading and is not functioning very well, and the Linux driver is not able to deal with those special case (like voltage fluctuation), . . . .

In another answer there, fossfreedom speculates that if it is not a voltage/current problem or a failing USB port/hub, then it is probably a kernel problem.

While it might, in my case, be due to the kernel, my problem has persisted through several kernel upgrades. The two computers that it happens on both have different brand keyboards and the boxes are different. The similarities between the two are that both are running Debian on Dell hardware.

In this thread in a linux/debian/user group, one person had similar problems to mine, but on very different hardware, and observed the problems with Debian but not with ArchLinux. Others there thought the problems were instead due to an inadequate power supply that might be overstressed when other system components suddenly demand too much power.

Another user reported random keyboard failure under Ubuntu and ArchLinux. After some speculation that the problem was due to X.org's keyboard settings, that user's problem was solved when he bought a new keyboard.

In sum, others have observed somewhat similar glitches and, unfortunately, the specific cause is very hard to diagnose: it could be in the power supply, in a cable, in a USB IC, in a USB driver, in a keyboard driver, or somewhere else in our very complex modern computing systems.


I am on Ubuntu 12.04 with Gigabyte keyboard plugged into a Dell Precision laptop.

My issue was getting none of the same characters when typing i.e. "ẹ" when I type "e" and then "."

I had to reboot, sometimes a couple times to get it working.. What I chanced upon was that it may be malware - and I found this really nice explanation of malware, viruses and the like: http://www.linux.org/threads/malware-and-antivirus-systems-for-linux.4455/

I used as (as described in the post)

sudo apt-get install clamav clamav-daemon clamav-freshclam

and the front end GUI

sudo apt-get install clamtk

It found 64 errors after running, I deleted them all, and, at least for the moment, my keyboard is behaving.


Consider Fn + NumLock as a first troubleshooting option.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .