I'm trying to install Cherokee webserver on Debian Wheezy. All the docs and websites that I've visited suggest that apt-get install cherokee will do it, but when I do that, I see:

$ apt-get install cherokee
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package cherokee

When running sudo add-apt-repository ppa:cherokee-webserver (as described in the docs), I see:

-bash: add-apt-repository: command not found

The docs says:


Install Cherokee from the apt repository
apt-get install cherokee cherokee-admin
Please, check the documentation for further

So I tried apt-get install cherokee cherokee-admin, which was also unable to locate the package. It doesn't make any sense: why would they tell you to use apt, if it's not available there? Some suggest that cherokee is dead, but I can see on the homepage it's very active, so something isn't right.

Should I build it from source?

On some forums they said that Cherokee never released a package for Wheezy. Is that true?

  • What does your /etc/apt/sources.list contain? Have you tried to update your apt cache via apt-get update?
    – Joseph R.
    Jul 12, 2013 at 18:08

2 Answers 2


Cherokee removed from Debian

I found this thread on the Cherokee mailing list which would seem to indicate that the package has been dropped from Debian all together.

Cherokee was removed from Testing back in November, and has been removed from Unstable yesterday. But you can introduce it as a new package without changing the packaging. If you become a DM, I can sponsor you the first upload, and afterwards you can take care of it by yourself.

missing add-apt-repository

You're missing the application add-apt-repository. You can install it by installing this package:

$ sudo apt-get install software-properties-common

Missing apps

On Debian and Ubuntu you can determine what package to install when you encounter a missing command line tool.

$ dpkg --search add-apt-repository
software-properties-common: /usr/bin/add-apt-repository
software-properties-common: /usr/share/man/man1/add-apt-repository.1.gz

You can also list the contents of a package by using dpkg-query:

$ dpkg-query -L software-properties-common | grep add-


You can also install this tool, apt-file to search for files and find out what package they're included in:

$ sudo apt-get install apt-file

The first time you run it:

$ apt-file search add-apt-repository
E: The cache is empty. You need to run 'apt-file update' first.

So update it:

$ sudo apt-file update

Now with the cache inplace:

$ apt-file search add-apt-repository
software-properties-common: /usr/bin/add-apt-repository
software-properties-common: /usr/share/man/man1/add-apt-repository.1.gz


  • thanks sir, i'm accepting your answer since i am indeed missing oftware-properties-common. As for cherokee, if it's not active, i'm going for nginx, i wanted to try hosting django on it, but it's not worth it
    – Lynob
    Jul 12, 2013 at 18:59
  • @Fischer - nginx. Yes I use this on several sites that I support and it's an excellent webserver. Great community and docs.
    – slm
    Jul 12, 2013 at 19:01

Cherokee was removed from Debian in April 2012 since maintainer abandoned the package. Unfortunately, the documentation hasn't been updated since then, and the PPA don't include debian-specific builds.

Should I build it from source?

That would be the best course of action. Use the guide that provides Cherokee that will build Cherokee for your system natively. You can, also, instead using make install use check-install that will create a .deb file that you can uninstall later.

On some forums they said that Cherokee never released a package for Wheezy, is that true?

Yes, the package was never released for Wheezy, only for Squeeze (oldstable). You can check the current status of the package here.

  • thanks a lot, i'm not gonna go for it, if there's no support for it, i don't really need it, i heard that it was better than njinx, wanted to give it a try, if no future support, i don't really have to install
    – Lynob
    Jul 12, 2013 at 18:57
  • @Fischer - nginx.
    – slm
    Jul 12, 2013 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.