3

I am having problems printing to the printer connected to my (SBS2003) business's network.

I know the IP of the printer and I can ping it and even print files from it by going to 192.168.0.50 in firefox and uploading a file.

If I do an nmap on the IP of the printer I get this:

jamesmaddison@development:~$ nmap 192.168.0.50

Starting Nmap 5.21 ( http://nmap.org ) at 2013-07-11 16:12 BST
Nmap scan report for 192.168.0.50
Host is up (0.46s latency).
Not shown: 991 closed ports
PORT      STATE SERVICE
21/tcp    open  ftp
23/tcp    open  telnet
80/tcp    open  http
443/tcp   open  https
515/tcp   open  printer
631/tcp   open  ipp
5900/tcp  open  vnc
9100/tcp  open  jetdirect
50001/tcp open  unknown

Nmap done: 1 IP address (1 host up) scanned in 4.55 seconds

I can't get my local cups server to print to it no matter what protocol I use. I am in the business workgroup and the printer even lists my computer in the workgroup.

I have tried:

smb://MASTERMAGNETS/SBSSRV/Sharp%20MX-M314N/
smb://jamesmaddison:password@MASTERMAGNETS/SBSSRV/Sharp%20MX-M314N/
socket://192.168.0.50:9100
ipp://192.168.0.50/ipp?version=1.0
lpd://192.168.0.50/lp

and all of the "Discovered Printers" that CUPS lists. (They're dnssd protocols)

The Printer is a Sharp MX-M314N. All Windows computers on the network can print to it fine, just my ubuntu machine that won't.

Here's what the CUPS error log says for the last job I tried. http://pastebin.com/YL7p1Zsp

And I often get a notification saying "Printer Error: printer error Printer Name: connecting-to-device"

Here's what nmap reports when I run it on the SBS

jamesmaddison@development:~$ nmap mastermagnets

Starting Nmap 5.21 ( http://nmap.org ) at 2013-07-11 16:35 BST
Nmap scan report for mastermagnets (192.168.0.2)
Host is up (0.00055s latency).
rDNS record for 192.168.0.2: mastermagnets.local
Not shown: 957 closed ports
PORT      STATE SERVICE
25/tcp    open  smtp
42/tcp    open  nameserver
53/tcp    open  domain
80/tcp    open  http
88/tcp    open  kerberos-sec
135/tcp   open  msrpc
139/tcp   open  netbios-ssn
389/tcp   open  ldap
443/tcp   open  https
444/tcp   open  snpp
445/tcp   open  microsoft-ds
464/tcp   open  kpasswd5
593/tcp   open  http-rpc-epmap
636/tcp   open  ldapssl
691/tcp   open  resvc
1025/tcp  open  NFS-or-IIS
1027/tcp  open  IIS
1042/tcp  open  unknown
1045/tcp  open  unknown
1046/tcp  open  unknown
1048/tcp  open  unknown
1049/tcp  open  unknown
1054/tcp  open  unknown
1081/tcp  open  unknown
1087/tcp  open  unknown
1094/tcp  open  unknown
1104/tcp  open  unknown
2301/tcp  open  compaqdiag
2381/tcp  open  unknown
3268/tcp  open  globalcatLDAP
3269/tcp  open  globalcatLDAPssl
3389/tcp  open  ms-term-serv
5633/tcp  open  unknown
6001/tcp  open  X11:1
6002/tcp  open  X11:2
6004/tcp  open  X11:4
6101/tcp  open  backupexec
6106/tcp  open  isdninfo
8080/tcp  open  http-proxy
8081/tcp  open  blackice-icecap
8082/tcp  open  blackice-alerts
8443/tcp  open  https-alt
10000/tcp open  snet-sensor-mgmt

Nmap done: 1 IP address (1 host up) scanned in 1.18 seconds[/CODE]

I just can't get it to work, the problem seems to be between Cups and the windows server as if I go to 192.168.0.50:9100 in firefox the printer prints the GET header it receives. I can also go to 192.168.0.50 and upload a file directly to the printer. Lastly I can ftp into the printer and upload files that way.

Here's what smbclient gives me:

~$ smbclient -U MASTERMAGNETS/JamesMaddison -L //SBSSRV


Sharename       Type      Comment
---------       ----      -------
Line100         Disk      
print$          Disk      Printer Drivers
C$              Disk      Default share
S$              Disk      Default share
Technical       Disk      
IRS             Disk      
Designjet 500-24 Printer   HP Designjet 500 24 by HP
Accounts        Disk      
RICOH           Printer   RICOH Aficio 1027
clients         Disk      Windows Small Business Server Client Setup
tsclient        Disk      
IPC$            IPC       Remote IPC
Resources$      Disk      "Event logging files"
FxsSrvCp$       Disk      Common Fax Cover Pages Folder
tsweb           Disk      
SHARP MX-M314N  Printer   192.168.0.50
ADMIN$          Disk      Remote Admin
faxclient       Disk      Microsoft Shared Fax Clients
ClientApps      Disk      Windows Small Business Server Client Applications
DLOAgent        Disk      Symantec DLO Share
Magnets-database files Disk      
Magnet-database files Disk      
D$              Disk      Default share
Users           Disk      Users Shared Folders
Public          Disk      
actsql          Disk      
SYSVOL          Disk      Logon server share
Address         Disk      "Access to address objects"
Confidential    Disk      
NETLOGON        Disk      Logon server share
SBSSRV.LOG      Disk      Exchange message tracking logs

Server               Comment
---------            -------
ANDY                
DESIGN1              
DESIGN2              
DESIGN3              
DEVELOPMENT          development server (Samba, Linux)
FRANK                
JOE                  
JONATHAN            
KIM                  Kim
ORDERPRINT           Purchase Order Printer
PHIL                
SBSSRV              
TERMSRV              

Workgroup            Master
---------            -------
MASTERMAGNETS        SBSSRV
  • I think you should look at the configuration of the printer. Your print queues names does not seems realistic. – MUY Belgium Oct 29 '17 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.