13

I recently installed Arch Linux and have it mostly set up. With many other Linux distributions, there is a tool that is used to configure the look and feel of the login screen. I would like to change the wallpaper used, the date/time format from something like "Sat 6:27 PM" to "26 Feb 11 18:27", and the refresh rate of the monitor (it's fine when I'm logged in, but not at the login screen).

Where can I find these configuration options or (preferably) a GNOME application to allow for me to make these configuration changes?

11

The ArchWiki is a very good source of information. This is where I found the following:

To configure the GDM theme use this command:

sudo -u gdm dbus-launch gnome-appearance-properties

For more configuration options, use this command:

sudo -u gdm dbus-launch gconf-editor

And modify the following hierarchies:

/apps/gdm/simple-greeter
/desktop/gnome/interface
/desktop/gnome/background

You may end up with an Xauth error. If that happens, try gksudo instead of sudo. If the error persists, you can do this:

xauth list $DISPLAY

This gives you the xauth cookie being used by your user. Copy the output, then run the following, replacing "" with the output of the previous command.

sudo su -u gdm
xauth add <cookie>
dbus-launch gnome-appearance-properties

This logs you in as the gdm user, adds the cookie, permitting gdm to use your display, and launches gnome-appearance-properties.

  • 1
    When I try to run "sudo -u gdm dbus-launch gconf-editor", I get "No protocol specified" and "Couldn't exec gconf-editor: No such file or directory". I'll re-read that page and poke around, though. – Thomas Owens Feb 27 '11 at 2:10
  • @thomas-owens I added some steps to try. – Shawn J. Goff Feb 27 '11 at 2:56
  • So I did this and launched gnome-appearance-properties, which is just the Appearance Preferences from System > Preferences > Appearance. There's no way to adjust anything about the login screen on that application. I'm now looking at gconf-editor, which I had to install separately. Nothing jumps out at me, but there are a ton of options, so I'll have to read some docs and poke around a little. – Thomas Owens Feb 27 '11 at 5:17
  • I should have added that the login screen is the background image for the gdm user. Previous versions of GDM supported themes, but it no longer does. – Shawn J. Goff Feb 27 '11 at 15:38
  • I get sudo: unkown user: gdm from doing what @ShawnJ.Goff suggests – Hatefiend Jan 8 '18 at 12:39
1

The only way I've found to do it was to modify/replace the file:

/usr/share/backgrounds/linuxmint/default_background.jpg

The file is 1920x1200 and I've only tried replacing it with another jpg of the same resolution.

You may want to make a backup of the original default_background.jpg just in case.

After replacing it you can test how the image will look by locking your computer.

  • much appreciated! – raucousloki Oct 30 '11 at 1:56
1

The only one that worked for me on Arch Linux:

sudo -u gdm dbus-launch gsettings set org.gnome.desktop.screensaver picture-uri 'file:///usr/share/backgrounds/gnome/picture.jpg'

Then, you can verify it worked:

sudo -u gdm gsettings get org.gnome.desktop.screensaver picture-uri

Or verify using dconf:

sudo -u gdm dconf read /org/gnome/desktop/screensaver/picture-uri
0

At least on my systems the default login provides a menu option to change the configuration from the login screen.

But the monitor refresh is not controlled by GDM, that is an X server configuration, edited in the xorg.conf file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.