I'm struggling quite a lot around ssh tunnels today.

First, here is my configuration:

  • My local machine, a PC with windows XP (ip=l.l.l.l)
  • My remote server, with a CentOs 5 installed (ip=x.x.x.x)

I'm very well able to connect to the remote using the putty interface with the root user: the terminal is asking for my credentials, which work.

However, while using the ssh command line (ssh -v root@x.x.x.x), my credentials are also wanted but they simply don't work. I'm copy-pasting the password in both cases from the same source, so I'm sure I entered it correctly.

Here is the debug output for ssh command line:

OpenSSH_3.8.1p1, OpenSSL 0.9.7d 17 Mar 2004 
debug1: Reading configuration data /etc/ssh_config 
debug1: Connecting to x.x.x.x:22 [x.x.x.x] port 22. 
debug1: Connection established. 
debug1: identity file /home/Seb/.ssh/identity type -1 
debug1: identity file /home/Seb/.ssh/id_rsa type -1 
debug1: identity file /home/Seb/.ssh/id_dsa type -1 
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3 
debug1: match: OpenSSH_5.3 pat OpenSSH* 
debug1: Enabling compatibility mode for protocol 2.0 
debug1: Local version string SSH-2.0-OpenSSH_3.8.1p1 
debug1: SSH2_MSG_KEXINIT sent 
debug1: SSH2_MSG_KEXINIT received 
debug1: kex: server->client aes128-cbc hmac-md5 none 
debug1: kex: client->server aes128-cbc hmac-md5 none 
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent 
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP 
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent 
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY 
debug1: Host 'x.x.x.x:22' is known and matches the RSA host key. 
debug1: Found key in /home/Seb/.ssh/known_hosts:4 
debug1: ssh_rsa_verify: signature correct 
debug1: SSH2_MSG_NEWKEYS sent 
debug1: expecting SSH2_MSG_NEWKEYS 
debug1: SSH2_MSG_NEWKEYS received 
debug1: SSH2_MSG_SERVICE_ACCEPT received 
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mi c,password debug1: Next authentication method: publickey 
debug1: Trying private key: /home/Seb/.ssh/identity 
debug1: Trying private key: /home/Seb/.ssh/id_rsa 
debug1: Trying private key: /home/Seb/.ssh/id_dsa 
debug1: Next authentication method: password root@x.x.x.x:22's password: 
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mi c,password 
Permission denied, please try again.

Here is the /var/log/secure extract:

Jul 10 02:26:50 sds-158 sshd[11549]: reverse mapping checking getaddrinfo for l.l.l.l.fibertel.com.ar [l.l.l.l] failed - POSSIBLE BREAK-IN ATTEMPT!
Jul 10 02:27:12 sds-158 sshd[11549]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=l.l.l.l  user=root
Jul 10 02:27:14 sds-158 sshd[11549]: Failed password for root from l.l.l.l port 3589 ssh2

Here is my sshd_config:

#       $OpenBSD: sshd_config,v 1.80 2008/07/02 02:24:18 djm Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/local/bin:/bin:/usr/bin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options change a
# default value.

Port 22
#AddressFamily any
#ListenAddress ::

# Disable legacy (protocol version 1) support in the server for new
# installations. In future the default will change to require explicit
# activation of protocol 1
Protocol 2

# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 1024

# Logging
# obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
SyslogFacility AUTHPRIV
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile     .ssh/authorized_keys
#AuthorizedKeysCommand none
#AuthorizedKeysCommandRunAs nobody

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no
PasswordAuthentication yes

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no
#KerberosUseKuserok yes

# GSSAPI options
#GSSAPIAuthentication no
GSSAPIAuthentication yes
#GSSAPICleanupCredentials yes
GSSAPICleanupCredentials yes
#GSSAPIStrictAcceptorCheck yes
#GSSAPIKeyExchange no

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
#UsePAM no
UsePAM yes

# Accept locale-related environment variables

#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#ShowPatchLevel no
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10
#PermitTunnel no
#ChrootDirectory none

# no default banner path
#Banner none

# override default of no subsystems
Subsystem       sftp    /usr/libexec/openssh/sftp-server

# Example of overriding settings on a per-user basis
#Match User anoncvs
#       X11Forwarding no
#       AllowTcpForwarding no
#       ForceCommand cvs server

Thank you for your help...

pd: I'm not sure where to post this. Superuser or here?

EDIT: Out of curiosity I tried plink and it works fine!! first shot! I'm confused now. Is it openssh command line that has a bug? For eventually interested fellow readers, here is the command line: plink -v -C -ssh -L root@x.x.x.x

migrated from serverfault.com Jul 11 '13 at 11:26

This question came from our site for system and network administrators.

  • Since PermitRootLogin is yes, Superuser. – Andrew B Jul 10 '13 at 1:53
  • 1
    @AndrewB why? Because it's bad practise? Just wondering, not questioning. – john Jul 10 '13 at 6:56
  • @Sebas ServerFault is for server administration in a professional capacity, and enabled remote root logins is not a setting that should be used in a production environment. – Andrew B Jul 10 '13 at 14:43
  • @AndrewB The root thing was for test purpose only. The final user will be a dummy user. – Sebas Jul 10 '13 at 15:56
  • have you tried other user instead of root, or using hostnames instead of IP addresses? – golimar Sep 5 '13 at 13:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.