2

I have created a new user with -e option to make it active for just 30 days. This user do ssh tunnel using Bitvise SSH Client for Windows. When the user account has expired bitvise shows a User Authentication Banner says "Your account has expired, Please contact your system administrator".The bitvise log says "User authentication banner received from the server". So i think this message come from server side.

How to change this message ? I am using debian 6.

User Authentication Banner

2 Answers 2

1

Messaging can be controlled through the Banner and Match commands in the sshd_config file. You can create Match sections which can override the global settings with custom ones based on the Match. So you could Match specific users and have different Banners for them vs. everyone else.

Match Group admins Address 1.2.3.0/24 
Banner /etc/ssh/someothermsgfile.txt
2
  • What is the content of the someothermsgfile.txt if i want to create expired banner ? or there is a manual about this ?
    – Yusufmm
    Commented Jul 10, 2013 at 15:39
  • It's covered in the man page for sshd_config.
    – slm
    Commented Jul 10, 2013 at 15:43
1

You can also enter "none" for the Banner, and nothing will be displayed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .