I plugged a Q-Tec 340R ATA-133 IDE RAID card, with two IDE connectors and support for up to four IDE drives, into an old P4 machine, attached two hard drives and managed to set up RAID0 and install Fedora. Things were going well, but I wanted to play around with various RAID set-ups, so a week later I got a few extra IDE drives, attached them, reset the RAID configuration and configured the four drives as a striped set. That's where things stopped working.

As soon as the Fedora (or CentOS, or any other distro's) installer starts looking at the storage devices, it throws up a warning that all drives in the RAID set need to be "re-initialized". If I re-initialize the drives, I can only use them individually, not as a RAID set. If I hit ignore, I'm told that "Disk sdb [and other] contains BIOS RAID metadata, but is not part of any recognized BIOS RAID sets. Ignoring disk sdb." Then it also notes there's an incorrect number of devices in the RAID array, presumably because it just ignored one or other of the disks.

I've subsequently tried dd-ing the whole disks, removing all data, but then of course I set up RAID again with the BIOS utility, and so metadata is added again, and I get the same errors.

Researching the error message of the disks containing RAID metadata, but not being part of any recognized BIOS RAID sets, all I find is people trying to use hard drives previously used in a RAID set-up, who now want to use them individually. I need to use these disks in a RAID set-up, but for some reason the Linux installer does not recognize them as such.

I've also tried reverting to a two-disk RAID0 setup, like the one I set up initially, but now that won't work either. What could this be? Is my card faulty? Did I miss something?

  • Just FYI, having a mirror as a IDE master/slave pair is a bad idea, as many failures will actually take out the entire channel. So you'll lose both halves of the mirror. (Also, the performance of simultaneous I/O to both the master and slave may not be so good...) – derobert Jul 9 '13 at 17:45
  • That appears to be a "fakeraid" card. I.e., the RAID is performed on the host CPU, not on the card. The only reason to use the RAID BIOS would be if you're trying to dual-boot Windows. – derobert Jul 9 '13 at 17:57
  • Strangely, however, it worked fine the first time around, with two striped disks (primary master, secondary master). Good point about the reliability of the master/slave pair, of course, but I'm not really worried about that for this particular computer (and at this point I'd be happy to just get RAID working with two disks). – redburn Jul 9 '13 at 18:53
  • 1
    If you're not dual booting, turn off the RAID BIOS and just use it as a IDE controller. Then use mdadm to build your arrays. (Which is easy to do in Debian-installer, and I assume in Fedora's as well) – derobert Jul 9 '13 at 21:45
  • 1
    Grub can boot from RAID... At least if you make a separate /boot partition which is RAID1 across all the disks (it only needs to be 256MB at most). You then install grub in the MBR (or BIOS boot partition, if EFI GPT) of each disk. – derobert Jul 11 '13 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.