5

I have two screens on my computer, but they all show the same image (i.e I can't activate dual screen).

I saw on some blogs that I need to configure xrandr for this, but it fails to do so. Here is the output xrandr returns:

sam@BARDT071:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1600 x 1200, maximum 1600 x 1200
default connected 1600x1200+0+0 0mm x 0mm
   1600x1200       0.0* 
   1280x1024       0.0  
   1280x960        0.0  
   1024x768        0.0  
   800x600         0.0  
   640x480         0.0  

It seems that only one screen is visible to my Debian system, even though I have two screens displaying something. Any pointers would be appreciated!

EDIT: I run xfce4, and going to Start -> Settings -> Display shows only one screen.

  • Have you tried the standard Gnome monitor configuration GUI? – jordanm Jul 9 '13 at 16:00
  • @jordanm I run xfce4 but I can give it a try. – S4M Jul 9 '13 at 16:02
  • I think XFCE has something similar in the settings manager. – jordanm Jul 9 '13 at 16:08
  • @jordanm yes, see my edit. – S4M Jul 9 '13 at 16:08
  • A brief X log snippet identifying your display hardware would be helpful. Different display cards and drivers have different features. – tripleee Jul 9 '13 at 17:15
7

You might want to take a look at this page, titled: XSF / How to use xrandr. For starters you could try this command:

$ xrandr --output VGA1 --right-of LVDS1

You can control the orientation of the monitors with respect to each other using these switches:

  • --right-of
  • --left-of
  • --above
  • --below
  • $ xrandr --output VGA1 --right-of LVDS1 Gves xrandr: Failed to get size of gamma for output default warning: output VGA1 not found; ignoring – eddy147 Nov 25 '16 at 13:29
1

I had this problem, and it had nothing to do with xfce or debian, but of problem with radeon driver, I didn't have some firmware, so I did this :

dpkg -i firmware-linux-nonfree_0.43_all.deb

Find the firmware here or here:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.