I have recently installed DD-WRT on my D-Link DIR-615 router (rev. D3). Everything seems fine but I cannot connect to some (most) FTP servers anymore. Any ideas what can cause this issue?


Passive/active doesn't make a difference.

I've discovered something interesting. I've set up a port range forwarding 1024-65535 | Both | for the testing purposes. After that I have enabled or disabled (it doesn't really matters it seems) the UPnP service and it let me connect to FTP but just for a few seconds.

  • Welcome to StackExchange. Here is a little tip. Just by reading the about page at the link near the search bar at the top, you get a badge. – Devyn Collier Johnson Jul 9 '13 at 12:45

This is an old topic, but someone might still find my solution useful: update your firmare. DD-WRT provides updated versions and the last one I could find here http://dd-wrt.com/site/support/other-downloads?path=others%2Feko%2FBrainSlayer-V24-preSP2%2F works. I can finally use FTP.

  • Are you using the same router? What version of DD-WRT do you currently have? I've managed to use SFTP and SSH all this time but would be nice to be able to access FTP again :) – Andrei Jul 20 '14 at 0:20
  • Not using the same router, but I had the same problem on my TP Link. Since last night I use this one: DD-WRT v24-sp2 (06/23/14) std (SVN revision 24461) FTP works. – conualfy Jul 20 '14 at 6:00
  • Awesome. Just upgraded to the same version (for my D-Link DIR 615d) and it works. Thank you fellow romanian! – Andrei Jul 20 '14 at 16:07
  • You are very welcome, @Andrei! – conualfy Jul 20 '14 at 21:47

I wonder if you're experiencing an issue with passive mode and these sites. As I understand it the ftp site makes a connection back to you, perhaps dd-wrt's firewall is blocking these back connections to your ftp client upon connecting?

If you run the command netstat -an on your dd-wrt box you'll likely see TCP connections waiting.

  • I have disabled the SPI Firewall but the problem still occurs. I don't have much experience with DD-WRT but I suppose I'd have to connect through SSH to run that command, right? – Andrei Jul 9 '13 at 17:22
  • I run the command through web interface and I've got the following (one of the many similar lines, just the port seems different): tcp 0 0 router_ip:80 local_ip:51773 TIME_WAIT – Andrei Jul 9 '13 at 17:31
  • @Andrei - try to ftp to one of the sites that wasn't working and then run that command. See if the IP address of the ftp site shows up with a TIME_WAIT. – slm Jul 9 '13 at 17:32
  • I'm seeing just the internal IP's here unfortunately. – Andrei Jul 9 '13 at 17:34
  • It's not really relevant what the websites are I think. One of them is hosted at MediaTemple and everything worked fine until yesterday when I installed DD-WRT. – Andrei Jul 9 '13 at 17:44

I've also experienced the same problem with FTP getting stuck, in my case at retrieving directory listing. After a lot of fiddling I was only able to make it work again by forwarding all ports to my computer's IP connected to the router while also disabling SPI Firewall.

Being unsatisfied with this workaround I followed @conualfy 's advice and updated to a newer firmware. I can confirm the FTP is now working perfectly without further fiddling after upgrading the firmware.

  • In my case the router is a Linksys WRT160NL and my current firmware is DD-WRT v24-sp2 (12/22/14)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.